Bug 207554 - crash while switching between applications (clicking ALT+TAB)
Summary: crash while switching between applications (clicking ALT+TAB)
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-16 11:42 UTC by Nadav Kavalerchik
Modified: 2009-09-23 21:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nadav Kavalerchik 2009-09-16 11:42:14 UTC
Application that crashed: kwin
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
i use nvidia 190.18 (debian amd64) and kde 4.3 (hp dv7 laptop)
it happens rarely. i can not reproduce 

(seems duplicate of bug 198533 and 203830 and 185084)

 -- Backtrace:
Application: KWin (kwin), signal: Aborted
[KCrash Handler]
#5  0x00007f8733eddd25 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007f8733ee0de1 in *__GI_abort () at abort.c:88
#7  0x00007f87342a7d45 in KWin::EffectsHandlerImpl::destroyInputWindow (this=0x218b920, w=18922757) at ../../kwin/effects.cpp:729
#8  0x00007f87251584bb in KWin::CoverSwitchEffect::abort (this=0x2348eb0) at ../../../kwin/effects/coverswitch/coverswitch.cpp:1421
#9  0x00007f872515b610 in KWin::CoverSwitchEffect::prePaintScreen (this=0x2348eb0, data=..., time=1) at ../../../kwin/effects/coverswitch/coverswitch.cpp:113
#10 0x00007f87342a74db in KWin::EffectsHandlerImpl::prePaintScreen (this=0x218b920, data=..., time=1) at ../../kwin/effects.cpp:112
#11 0x00007f87342a74db in KWin::EffectsHandlerImpl::prePaintScreen (this=0x218b920, data=..., time=1) at ../../kwin/effects.cpp:112
#12 0x00007f872512b8ec in KWin::LoginEffect::prePaintScreen (this=0x233fd30, data=..., time=1) at ../../../kwin/effects/login/login.cpp:52
#13 0x00007f87342a74db in KWin::EffectsHandlerImpl::prePaintScreen (this=0x218b920, data=..., time=1) at ../../kwin/effects.cpp:112
#14 0x00007f87342a74db in KWin::EffectsHandlerImpl::prePaintScreen (this=0x218b920, data=..., time=1) at ../../kwin/effects.cpp:112
#15 0x00007f872517f2aa in KWin::TrackMouseEffect::prePaintScreen (this=0x22e5a80, data=..., time=1) at ../../../kwin/effects/trackmouse/trackmouse.cpp:66
#16 0x00007f87342a74db in KWin::EffectsHandlerImpl::prePaintScreen (this=0x218b920, data=..., time=1) at ../../kwin/effects.cpp:112
#17 0x00007f87342a74db in KWin::EffectsHandlerImpl::prePaintScreen (this=0x218b920, data=..., time=1) at ../../kwin/effects.cpp:112
#18 0x00007f873429269e in KWin::Scene::paintScreen (this=0x21e86b0, mask=0x7fff0c8967fc, region=0x7fff0c896910) at ../../kwin/scene.cpp:113
#19 0x00007f87342a147f in KWin::SceneOpenGL::paint (this=0x21e86b0, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:746
#20 0x00007f873428d9d2 in KWin::Workspace::performCompositing (this=0x221a560) at ../../kwin/composite.cpp:420
#21 0x00007f8734229c3a in KWin::Workspace::qt_metacall (this=0x221a560, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff0c896aa0) at ./workspace.moc:473
#22 0x00007f873049a682 in QMetaObject::activate (sender=0x221a988, from_signal_index=<value optimized out>, to_signal_index=4, argv=0xffffffffffffffff) at kernel/qobject.cpp:3112
#23 0x00007f8730494bf3 in QObject::event (this=0x221a988, e=0x1310) at kernel/qobject.cpp:1074
#24 0x00007f8730bc780d in QApplicationPrivate::notify_helper (this=0x1ff3b90, receiver=0x221a988, e=0x7fff0c897150) at kernel/qapplication.cpp:4056
#25 0x00007f8730bcf86a in QApplication::notify (this=0x7fff0c8974c0, receiver=0x221a988, e=0x7fff0c897150) at kernel/qapplication.cpp:4021
#26 0x00007f8733ab343b in KApplication::notify (this=0x7fff0c8974c0, receiver=0x221a988, event=0x7fff0c897150) at ../../kdeui/kernel/kapplication.cpp:302
#27 0x00007f873048551c in QCoreApplication::notifyInternal (this=0x7fff0c8974c0, receiver=0x221a988, event=0x7fff0c897150) at kernel/qcoreapplication.cpp:610
#28 0x00007f87304b1826 in QCoreApplication::sendEvent (this=0x1ff78b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#29 QTimerInfoList::activateTimers (this=0x1ff78b0) at kernel/qeventdispatcher_unix.cpp:572
#30 0x00007f87304adc9d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#31 0x00007f8729f6221a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0x00007f8729f65a78 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0x00007f8729f65c2c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0x00007f87304adbff in QEventDispatcherGlib::processEvents (this=0x1fd96a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#35 0x00007f8730c5e64f in QGuiEventDispatcherGlib::processEvents (this=0x1310, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#36 0x00007f8730483de2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f87304841b4 in QEventLoop::exec (this=0x7fff0c897400, flags=...) at kernel/qeventloop.cpp:201
#38 0x00007f8730486424 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#39 0x00007f8734241ae8 in kdemain (argc=3, argv=0x7fff0c8979a8) at ../../kwin/main.cpp:522
#40 0x00007f8733eca5c6 in __libc_start_main (main=0x400710 <main>, argc=3, ubp_av=0x7fff0c8979a8, init=0x400740 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fff0c897998) at libc-start.c:222
#41 0x0000000000400649 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 198533

Reported using DrKonqi
Comment 1 Martin Flöser 2009-09-16 11:57:23 UTC
SVN commit 1024275 by graesslin:

Adding a safety check in coverswitch so that the input window is not destroyed twice.
BUG: 207554

 M  +7 -2      coverswitch.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1024275
Comment 2 Martin Flöser 2009-09-23 21:54:07 UTC
SVN commit 1027306 by graesslin:

Backport r1024275: Adding a safety check in coverswitch so that the input window is not destroyed twice.
CCBUG: 207554


 M  +7 -2      coverswitch.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1027306