Bug 207115 - Directory not loading when clicking on svg file
Summary: Directory not loading when clicking on svg file
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.0
Platform: openSUSE RPMs Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
: 278850 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-11 21:31 UTC by Todd
Modified: 2013-07-23 14:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2009-09-11 21:31:30 UTC
Version:            (using KDE 4.3.1)
Installed from:    SuSE RPMs

When I open an svg file from dolphin into gwenview, the directory the file is located in does not get loaded.  In the Browse view, the directory line is blank.  It doesn't even load the file kio slave, I have to select the kio slave before I can paste a directory.  The back and forward buttons also do not work.  However, if I navigate to a folder that contains svg files from within gwenview, it seems to work just fine.  The same thing happens if I try to open an svg file in gwenview from nautilus, so it isn't a dolphin-specific problem.
Comment 1 Aurelien Gateau 2010-01-16 15:48:40 UTC
I could reproduce this bug in 4.3, but it seems to works for me with 4.4 so I am closing this report. If you still have the problem please reopen it.
Comment 2 Todd 2010-09-24 17:49:54 UTC
This is happening again in KDE 4.5.1.
Comment 3 Todd 2010-10-08 19:15:45 UTC
Still present in 4.5.2.
Comment 4 Todd 2010-11-04 17:03:43 UTC
This problem is still happening in 4.5.3.  This makes it really hard to deal with svg files.  Gwenview essentially becomes a single picture viewer, it is impossible to open an svg and then navigate to another one.
Comment 5 Aurelien Gateau 2010-12-17 23:15:08 UTC
This is fixed (hopefully for good) in trunk. Will be in 4.6.
Comment 6 Todd 2012-03-17 19:51:31 UTC
*** Bug 278850 has been marked as a duplicate of this bug. ***
Comment 7 Todd 2012-03-17 19:52:15 UTC
This is happening again in KDE 4.8.1.
Comment 8 Todd 2013-02-08 13:27:29 UTC
This is still a problem in KDE SC 4.10
Comment 9 Aurelien Gateau 2013-07-03 15:28:37 UTC
Can you try: https://git.reviewboard.kde.org/r/111362/ ?
Comment 10 Aurelien Gateau 2013-07-23 14:14:37 UTC
Git commit 3a697c0c0ea56ea6dcb6c95a37ec7f6e659f3b71 by Aurélien Gâteau.
Committed on 23/07/2013 at 13:24.
Pushed by gateau into branch 'KDE/4.11'.

Fix two related bugs with svg support

1. Do not treat .svgz as archives
2. Fix directory not loaded when started with a .svg as argument

Posted for review on https://git.reviewboard.kde.org/r/111362/ but the changes
did not get reviewed. I am committing them nevertheless because I want the bug
to be fixed in rc2 and my personal testing did not spot any issue.

FIXED-IN: 4.11.0
Related: bug 321825


http://commits.kde.org/gwenview/3a697c0c0ea56ea6dcb6c95a37ec7f6e659f3b71