Bug 204391 - Juk skips every second track on windows
Summary: Juk skips every second track on windows
Status: RESOLVED FIXED
Alias: None
Product: juk
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Scott Wheeler
URL:
Keywords:
: 208429 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-19 12:11 UTC by Cyril Brosch
Modified: 2011-05-05 03:52 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch to fix skipping tracks (1.14 KB, patch)
2009-10-29 13:51 UTC, Kåre Särs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cyril Brosch 2009-08-19 12:11:06 UTC
Version:           3.3 (using KDE 4.3.0)
OS:                MS Windows
Installed from:    MS Windows

No matter whether I start at the beginning of a playlist or in the middle, whether it is to be played linearly or in random mode, whether it is a file from the local drive or a musci player, Juk plays the first song, then switches to the next, but after a second or so it goes on to the next. This third song is played normally, but the next is skipped again and so on.
I can play the skipped songs by pressing the back-button without problems.

As I use Juk on Windows only, I haven't tested it on Linux and with other files than mp3.
Comment 1 Cyril Brosch 2009-08-19 12:17:58 UTC
I forgot: This happens only when Juk goes on to the next track on it's own (because the song is over), when I press the nex-button while a song is playing, the next song is will be played without skipping.
Comment 2 Michael Pyne 2009-08-19 23:16:00 UTC
I take it that Phonon on Windows does not support having two AudioOutput objects simultaneously (JuK does this to support crossfading).  This is why you don't see it when you click next track manually, as JuK does not crossfade in this case.

AFAIK this is something Phonon is supposed to be able to do (up to the operating system limit at least).  You may want to check Nokia's Qt development bugtracker (from http://qt.nokia.com/) to see if it is a known bug.  I'll leave this open for now in case it turns out that JuK is using Phonon incorrectly (but I doubt it ;)
Comment 3 Cyril Brosch 2009-08-20 13:08:44 UTC
Thanks for clarification, I think a file a bug report to Qt (I didn't find anything related on their bug tracker).

Do I see correctly, that there is no possibility to disable crossfading in Juk in the meantime?
Comment 4 Michael Pyne 2009-08-20 22:46:36 UTC
Disabling crossfading is an option that always hovers right near the top of my priority list without ever quite managing to make it there. :(
Comment 5 Michael Pyne 2009-08-23 04:43:18 UTC
bug 165786 (add option to disable crossfading) is now fixed.
Comment 6 Guido Winkelmann 2009-10-12 04:45:41 UTC
I have nearly the exact same problem under Gentoo Linux (using KDE 4.3.2), except it's not always every second song that is skipped; it's more random thn that and not easily reproducable, and also a bit rarer.

This used to happen a lot more often KDE 4.2.x, if that helps.
Comment 7 Kåre Särs 2009-10-22 14:31:24 UTC
Hi,

I have the same problem on Kubuntu (9.04 with PPA packages of KDE 4.3.2)

I applied the patch from bug 165786 and I still get the same result. The only difference is that I do not notice it as easily as I do not hear the beginning of the skipped track when crossfading is turned off.

What I have noticed tho is that I get TagLib warnings in the console:
...
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Properties::read() -- Page headers were invalid.
...
Comment 8 Kåre Särs 2009-10-22 19:13:31 UTC
I have the same setup on my home computer (except hardware), but there I have no problem.
Comment 9 Martin Koller 2009-10-29 11:03:08 UTC
I see the same problem with KDE 4.3.2 (Juk 3.3) on openSuse 11.1.
Every second song is skipped after 2 seconds or so.
I see no setting to disable crossfading in Juk.
Comment 10 Kåre Särs 2009-10-29 13:51:31 UTC
Created attachment 37944 [details]
Patch to fix skipping tracks

This patch fixes it for me.

The problem is that slotFinished() is called from the non-playing Phonon::MediaObject and that results in the skipping.
Comment 11 Michael Pyne 2009-10-30 02:03:50 UTC
SVN commit 1042531 by mpyne:

Apply a modified patch by Kåre Särs to try and solve bug 204391 (JuK skips every second
track on Windows).  I guess the Qt Phonon backend on Windows doesn't emit the aboutToFinish
signal, that's the only thing I can think of offhand that would cause this.  Either way the
patch doesn't hurt so in it goes. (This applies to KDE 4.4, will backport).

CCBUG:204391


 M  +6 -1      playermanager.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1042531
Comment 12 Michael Pyne 2009-10-30 02:50:44 UTC
SVN commit 1042537 by mpyne:

Backport fix for bug 204391 to KDE 4.3.3 or 4.3.4 (we'll see who wins the race!)
This patch from Kåre Särs should fix the issue of JuK skipping every other track on
Windows (and possibly elsewhere, depending on how useful/lousy your Phonon backend is).

If it doesn't fix the bug, just reopen.

BUG:204391


 M  +6 -1      playermanager.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1042537
Comment 13 Michael Pyne 2011-05-05 03:52:10 UTC
*** Bug 208429 has been marked as a duplicate of this bug. ***