Bug 200531 - track and album length are not displayed for music streamed from Jamendo
Summary: track and album length are not displayed for music streamed from Jamendo
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.3-GIT
Platform: OpenSUSE Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-17 11:20 UTC by Stefan Majewsky
Modified: 2009-12-17 06:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of the wrong track and album lengths (117.44 KB, image/png)
2009-07-17 11:22 UTC, Stefan Majewsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Majewsky 2009-07-17 11:20:36 UTC
Version:           2.1.1 (using KDE 4.2.96)
Installed from:    SuSE RPMs

The short description says it all. See screenshot in first comment.
Comment 1 Stefan Majewsky 2009-07-17 11:22:48 UTC
Created attachment 35411 [details]
Screenshot of the wrong track and album lengths

Note that this only affects the playlist. The playback slider at the top correctly displays the times for the current track.
Comment 2 Radu Benea 2009-07-17 11:47:14 UTC
works for me Amarok
Version 2.2-SVN
Using KDE 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
Comment 3 Myriam Schweingruber 2009-07-17 12:04:06 UTC
This is solved in 2.2-SVN
Comment 4 Stefan Majewsky 2009-08-23 20:54:48 UTC
Please reopen this bug. I can reproduce it with 2.2-GIT (commit 31c784de15fb902d83fb5fa7ea90eafb3e191522, which was current today around noon).
Comment 5 Myriam Schweingruber 2009-08-23 23:31:11 UTC
JFYI, Stefan, as the initial reporter you can reopen it yourself
Comment 6 Stefan Majewsky 2009-08-23 23:53:02 UTC
No, unfortunately I couldn't, and I also wonder why. I could only change the status to RESOLVED, CLOSED or VERIFIED.
Comment 7 Nikolaj Hald Nielsen 2009-12-16 14:03:46 UTC
commit 704b862c6890a4c162393497dc51ccc8575b0e21
Author: Nikolaj Hald Nielsen <nhnFreespirit@gmail.com>
Date:   Wed Dec 16 13:37:35 2009 +0100

    Fix track lengths for Jamendo tracks.
    A few were already working, but most were not. These should all be fixed now.
    BUG: 200531
Comment 8 Nikolaj Hald Nielsen 2009-12-17 06:17:27 UTC
commit 704b862c6890a4c162393497dc51ccc8575b0e21
Author: Nikolaj Hald Nielsen <nhnFreespirit@gmail.com>
Date:   Wed Dec 16 13:37:35 2009 +0100

    Fix track lengths for Jamendo tracks.
    A few were already working, but most were not. These should all be fixed now.
    BUG: 200531

diff --git a/src/services/jamendo/JamendoXmlParser.cpp b/src/services/jamendo/JamendoXmlParser.cpp
index 1584f1c..ad2d1f9 100644
--- a/src/services/jamendo/JamendoXmlParser.cpp
+++ b/src/services/jamendo/JamendoXmlParser.cpp
@@ -378,7 +378,7 @@ JamendoXmlParser::readTrack()
             else if( localname == "id" )
                 id = m_reader.readElementText();
             else if( localname == "duration" )
-                length = m_reader.readElementText().toInt() * 1000;
+                length = m_reader.readElementText().toFloat() * 1000;
             else if ( localname == "numalbum" )
                 trackNumber = m_reader.readElementText();
             else if ( localname == "id3genre" )