Bug 197842 - "Stop after track" icon appearing twice on album header
Summary: "Stop after track" icon appearing twice on album header
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.3-GIT
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: 2.3.0
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-25 15:33 UTC by Ralf Jung
Modified: 2010-01-06 20:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot showing the two "stop" symbols (10.04 KB, image/png)
2009-06-25 15:33 UTC, Ralf Jung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Jung 2009-06-25 15:33:12 UTC
Version:           2.2-SVN (using 4.2.2 (KDE 4.2.2), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.28-13-generic

When I select the track which forms the header of an album to "Stop after track", the stop icon appears twice. The icons for the queue correctly appear only once. I attached a screenshot showing the problem.
Comment 1 Ralf Jung 2009-06-25 15:33:55 UTC
Created attachment 34802 [details]
Screenshot showing the two "stop" symbols
Comment 2 Myriam Schweingruber 2009-06-25 19:09:09 UTC
Confirmed, it shows once in the album header, once on the first track.
Comment 3 Ralf Jung 2009-09-05 10:44:59 UTC
Re-testing because of Beta release: The issue still exists in current git (4242c786fb3612ad157d167a5b841e7d3a66af08)
Comment 4 Myriam Schweingruber 2009-11-06 14:34:25 UTC
Still present in current git.
Comment 5 Ralf Jung 2009-11-14 11:10:18 UTC
Confirmed for KDE 4.3.2, Amarok 2.2, Kubuntu packages
Comment 6 Myriam Schweingruber 2009-11-16 14:09:42 UTC
Setting target.
Comment 7 Myriam Schweingruber 2009-11-16 15:36:16 UTC
Just tried again with current git: this only happens for the first track of an Album or group of podcasts, not, if the option is activated for any of the following tracks.
Comment 8 Nikolaj Hald Nielsen 2010-01-06 20:11:58 UTC
commit be466f36804ee402cf14c8b399f1edeb497c978b
Author: Nikolaj Hald Nielsen <nhnFreespirit@gmail.com>
Date:   Thu Dec 17 12:11:49 2009 +0100

    Fix a number of cases where "markers" such as "current track", "stop after this track" and the likes would get shown in both group headers and the first track.
    Also fix markers incorrectly getting shown when using the inline editor on the first track in a group.
    BUG: 197842


This was fixed a while back, but the automatic bug closing was not working at this time, so this bug was not correctly closed.