Bug 193093 - Text centered on mandrakeitalia.org
Summary: Text centered on mandrakeitalia.org
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-18 10:42 UTC by Diego
Modified: 2009-05-23 04:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego 2009-05-18 10:42:56 UTC
Version:           4.2.3 (KDE 4.2.3) (using 4.2.3 (KDE 4.2.3), Arch Linux)
Compiler:          gcc
OS:                Linux (i686) release 2.6.29-ARCH

This is always reproducible and easy to see: go to www.mandrakeitalia.org.

Some text (e.g. news titles) will be centered instead of beign left aligned (as seen in other browsers like Firefox).

If you need screens or more infos just let me know.
Comment 1 Germain Garand 2009-05-20 03:44:09 UTC
yes, that's because of a mozilla hack supposed to forcibly reset text-align at table boundaries - for whatever reason.

Where it becomes completely silly, reading the actual mozilla source code, is that they did it only for center and right... behold:

data:text/html,<!doctype html>
<div dir="LTR" align="right"><table width=100%><tr><td>If I am left aligned...</table></div>
<div dir="RTL" align="left"><table width=100%><tr><td>...then I definetly should be right aligned!</table></div>
Comment 2 Germain Garand 2009-05-22 06:43:28 UTC
SVN commit 971235 by ggarand:

don't allow special aligment values to percolate through tables even
in strict mode, as it isn't Mozilla-compatible.

BUG: 193093


 M  +9 -0      cssstyleselector.cpp  
 M  +1 -0      quirks.css  


WebSVN link: http://websvn.kde.org/?view=rev&revision=971235
Comment 3 Germain Garand 2009-05-23 04:54:30 UTC
SVN commit 971652 by ggarand:

automatically merged revision 971235:
don't allow special aligment values to percolate through tables even
in strict mode, as it isn't Mozilla-compatible.

BUG: 193093

 M  +9 -0      cssstyleselector.cpp  
 M  +1 -0      quirks.css  


WebSVN link: http://websvn.kde.org/?view=rev&revision=971652