Bug 191999 - Printing PDF/PS files in konqueror does not work properly
Summary: Printing PDF/PS files in konqueror does not work properly
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 173109 179021 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-08 08:28 UTC by A.S.
Modified: 2010-02-12 05:20 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A.S. 2009-05-08 08:28:44 UTC
Version:           4.2.2 (KDE 4.2.2) (using 4.2.3 (KDE 4.2.3), Kubuntu packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.28-11-generic

If I print PDF or PS files in konqueror, the result is not the expected.

There ist only some of the text and other elements of the webpage in the file (not only some pictures missing).
Comment 1 A.S. 2009-05-08 09:08:15 UTC
I am using Kubuntu 9.04 with KDE 4.2.3. But I have had the problem to on Kubuntu 9.04 with KDE 4.2.2 and on Kubuntu 8.10 with KDE 4.x.x.
Comment 2 A.S. 2009-06-24 09:09:35 UTC
This problem still exists in KDE 4.2.90 (KDE 4.3 Beta2).
Comment 3 A.S. 2009-07-08 10:26:30 UTC
This problem still exists in KDE 4.2.95 (KDE 4.3 RC1)
Comment 4 A.S. 2009-09-30 18:42:55 UTC
This problem still exists in KDE 4.3.1.

But if I use the webkit-kpart the result looks much better, even if the buttons are not painted correctly.
Comment 5 Germain Garand 2010-02-04 10:01:31 UTC
*** Bug 173109 has been marked as a duplicate of this bug. ***
Comment 6 Germain Garand 2010-02-04 10:05:37 UTC
*** Bug 179021 has been marked as a duplicate of this bug. ***
Comment 7 Germain Garand 2010-02-12 05:20:36 UTC
SVN commit 1088979 by ggarand:

great, looks like these two Qt regressions have finally been fixed,
so we can enable back the optimized code and close all the printing bugs
that closing/restoring the QPainter triggered

I'll do that in two commits so that problems can be pin-pointed :

1) stop ending the QPainter before painting widgets to buffers,
 it's not needed anymore and Qt has poor support for that.

 Fixes printing on pages with form widgets.

BUG: 197402
BUG: 214352
BUG: 191999

 M  +4 -10     render_replaced.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1088979