Bug 185465 - Amarok::Slider doesn't support RTL layouts
Summary: Amarok::Slider doesn't support RTL layouts
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.0.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-24 19:53 UTC by إسلام الشيخ
Modified: 2009-12-09 11:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description إسلام الشيخ 2009-02-24 19:53:10 UTC
Version:           2.0.1 (using 4.2.00 (KDE 4.2.0), Kubuntu packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.28-8-generic

Hi

In Right to left

When clicking on Track time bar , the events is coming as swapped 

That mean if I click on the right the time move as I click on the left !!

I think The problem is on right & left events swapped
Comment 1 Mark Kretschmann 2009-02-27 10:58:08 UTC
Ok, this sounds like a valid report to me. We should fix this before 2.1 release.
Comment 2 Seb Ruiz 2009-04-12 09:00:36 UTC
SVN commit 952511 by seb:

Fix slider mouse events on RTL layouts
BUG: 185465

 M  +1 -0      ChangeLog  
 M  +43 -19    src/widgets/SliderWidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=952511