Bug 184744 - [PATCH] iPhone not detected by MediaDeviceMonitor::isIpod
Summary: [PATCH] iPhone not detected by MediaDeviceMonitor::isIpod
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/iPod iPhone (show other bugs)
Version: 2.0.1
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-18 03:24 UTC by Keith Gable
Modified: 2011-12-20 11:37 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Return true in isIpod if iPhone is attached. (511 bytes, patch)
2009-02-18 03:25 UTC, Keith Gable
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Gable 2009-02-18 03:24:33 UTC
Version:           2.0.0.1 (using KDE 4.2.0)
Compiler:          gcc 4.3.2 
OS:                Linux
Installed from:    Gentoo Packages

I'm wanting to get my iPhone (supported just like an iPod at this point) working on Amarok 2.0. Probably a good first step is to get isIpod to return true for iPhone. Attaching patch.

I'm new to Amarok's code so I have no idea where the ipodDetected() and connectIpod() functions are defined. It does look however that if I could get HAL to store volume mount point for my iPhone, it would work properly in Amarok. Right now, I'm using sshfs to mount it. There is such a thing as iFuse, which does the AFP-over-USB thing needed to make the iPhone work. But that still doesn't really help me if I can't get HAL to understand where the mount point is located. (Is there a HAL policy file modification that can possibly make this work? NTFS-3G sets it so it must be possible)
Comment 1 Keith Gable 2009-02-18 03:25:30 UTC
Created attachment 31429 [details]
Return true in isIpod if iPhone is attached.

Attaching patch
Comment 2 Seb Ruiz 2009-04-11 11:33:46 UTC
SVN commit 952165 by seb:

Detect iPhones
BUG: 184744

 M  +2 -2      MediaDeviceMonitor.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=952165
Comment 3 Jonathan Thomas 2009-04-24 15:43:55 UTC
This doesn't seem to be fixed yet in trunk: https://launchpad.net/bugs/362182
Comment 4 Seb Ruiz 2009-04-26 05:55:20 UTC
This patch was indeed commited to trunk, so please don't reopen this report.

Regardless, I don't see how we can solve the iPhone/touch connection problem without it being solved in upstream with a hal register.