Bug 183821 - autoselect all text in location line edit with Ctrl+L
Summary: autoselect all text in location line edit with Ctrl+L
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 291845 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-09 20:15 UTC by Martin Kunev
Modified: 2012-08-13 05:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Kunev 2009-02-09 20:15:43 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    Debian testing/unstable Packages

When I open new tab using the keyboard shortcut (Ctrl+t in my case), dolphin duplicates the current tab instead of opening new blank tab.
Comment 1 Peter Penz 2009-02-10 07:52:25 UTC
Thanks for the report, but what's the benefit of having an empty tab? If you want to show a custom URL, you anyhow have to select a place or enter an URL.
Comment 2 Martin Kunev 2009-02-10 13:04:03 UTC
The benefit is that there is nothing in the location bar so you don't need to select its content in order to enter different URL. That is not a big problem but it slows me down. I think it will be better to have one shortcut for duplicate current tab and one for open new blank tab.
Comment 3 Martin Kunev 2009-02-10 13:07:12 UTC
The other option is at least to select the location bar content automatically. The current behaviour is different from konqueror's so I think it is not good.
Comment 4 Shaun Reich 2009-03-10 01:48:14 UTC
Are you aware of the clear all text button in the editable location?

Does this functionality satisfy you perhaps?
Comment 5 Nick Shaforostoff 2012-02-22 17:13:30 UTC
i vote for autoselecting the path when user presses Ctrl+L. This behaviour is already used by all [sane] web-browsers
Comment 6 Nick Shaforostoff 2012-02-22 18:20:59 UTC
Git commit 6db52722096b4ac5f7464dc54a95491fde4e75f3 by Nick Shaforostoff.
Committed on 22/02/2012 at 19:23.
Pushed by shaforo into branch 'KDE/4.8'.
MERGE: yes
FIXED-IN: 4.8.1

autoselect all text in location line edit with Ctrl+L.
(behave like web-browsers do)

M  +6    -7    dolphin/src/dolphinmainwindow.cpp

http://commits.kde.org/kde-baseapps/6db52722096b4ac5f7464dc54a95491fde4e75f3
Comment 7 Peter Penz 2012-02-22 19:55:57 UTC
Git commit 34937e306e717c971a26294ac3ef62108b235007 by Peter Penz.
Committed on 22/02/2012 at 20:53.
Pushed by ppenz into branch 'KDE/4.8'.

Revert "BUG: 183821"

This reverts commit 6db52722096b4ac5f7464dc54a95491fde4e75f3.

No review-request has been put on git.reviewboard.kde.org and
it has not been agreed that this behavior gets changed.

M  +7    -6    dolphin/src/dolphinmainwindow.cpp

http://commits.kde.org/kde-baseapps/34937e306e717c971a26294ac3ef62108b235007
Comment 8 Peter Penz 2012-02-22 20:01:09 UTC
@Nick: Please never push a bugfix without putting it on git.reviewboard.org or a previous review from the Dolphin core developers.
Comment 9 Peter Penz 2012-02-22 20:04:51 UTC
@Nick: Before putting it on the reviewboard for discussion - please explain why the existing action "Replace Location (F6)" is not sufficient for your requested behavior. F6 already does what you tried to patch to Ctrl+L...
Comment 10 Nick Shaforostoff 2012-02-22 21:26:30 UTC
(on reviewboard): ok. sorry for not doing this initially.

selecting all text with Ctrl+L is consistent with behaviour of web-browsers
Comment 11 Nick Shaforostoff 2012-02-22 21:27:54 UTC
and with suggested behaviour of Ctrl+L 'Replace location' action is not needed anymore.
Comment 12 Peter Penz 2012-02-23 09:15:10 UTC
The current behavior:
- Editable Location (Ctrl+L): Allow to append a path to the existing location
- Replace Location (F6): Selects the current location to be able to replace it
is the result of discussions with users after Dolphin 1.0 has been released. There are users out there that rely on this behavior and we cannot just change it until we have really good reasons for it (and it is an absolute no-go to do this on a bugfix release like 4.8.1 where we have no chance to get feedback).

> selecting all text with Ctrl+L is consistent with behaviour of web-browsers
> and with suggested behaviour of Ctrl+L 'Replace location' action is
> not needed anymore.

In retrospective it might have been better to exchange the shortcuts, so that Ctrl+L calls "Replace Location" and F6 "Editable Location". But removing the action which simply allows appending something to a path is no good idea I'd say: In opposite to a webbrowser (at least for me) appending a path in a filemanager is done more often than replacing a path.

What I'd propose is that we leave this bug-report open, so that we can apply duplicate reports and users can vote for this issue. If there seems to be a big demand for a change to have this consistent with web-browsers, we can think about exchanging the shortcuts for a next major release.
Comment 13 Jekyll Wu 2012-08-10 14:55:44 UTC
*** Bug 291845 has been marked as a duplicate of this bug. ***
Comment 14 Jekyll Wu 2012-08-13 05:27:09 UTC
Git commit 2a604cba5d12e3776c63c04e7a1f41b40b3c86ab by Jekyll Wu.
Committed on 12/08/2012 at 16:18.
Pushed by jekyllwu into branch 'master'.

Swap shortcuts of "editable_location" and "replace_location" actions

That makes "Ctrl+L" less surprising to users who use it frequently in
web browsers
FIXED-IN: 4.10.0
REVIEW: 105994

M  +2    -2    dolphin/src/dolphinmainwindow.cpp

http://commits.kde.org/kde-baseapps/2a604cba5d12e3776c63c04e7a1f41b40b3c86ab