Bug 181840 - Crash on undo of Cut of some text
Summary: Crash on undo of Cut of some text
Status: RESOLVED DUPLICATE of bug 175911
Alias: None
Product: kword
Classification: Unclassified
Component: flake-texttool (show other bugs)
Version: git
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-25 08:22 UTC by T Zachmann
Modified: 2009-01-25 23:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description T Zachmann 2009-01-25 08:22:02 UTC
Version:           svn (using KDE 4.1.3)
OS:                Linux
Installed from:    Compiled From Sources

Use the odt file from bug 180944

http://bugs.kde.org/attachment.cgi?id=30559

Go to the second page and delete the following text by pressing cut in the meubar

vůči 		Lenovo Technology B.V. organizační složce 
Praha 4, Chodov, V Parku č.o.4,č.p.2294, PSČ 148 00
IČ: 272 43 869

undo the change

-> crash

Here is the backtrace:
Application: KWord (kword), signal SIGABRT

Thread 1 (Thread 0xb5a0b6c0 (LWP 23685)):
[KCrash Handler]
#6  0xb7fd2410 in __kernel_vsyscall ()
#7  0xb691d085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb691ea01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb6c0a34d in qt_message_output (msgType=QtFatalMsg, buf=0xbfbe92e0 "ASSERT: \"i >= 0 && i < size()\" in file ../../include/QtCore/../../src/corelib/tools/qstring.h, line 644")
    at global/qglobal.cpp:2102
#10 0xb6c0a3d1 in qFatal (msg=0xb6d5fc98 "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2303
#11 0xb6c0a829 in qt_assert (assertion=0xb76fccde "i >= 0 && i < size()", file=0xb76fcc98 "../../include/QtCore/../../src/corelib/tools/qstring.h", line=644) at global/qglobal.cpp:1872
#12 0xb70c3aba in QString::at (this=0x8e244cc, i=17) at ../../include/QtCore/../../src/corelib/tools/qstring.h:644
#13 0xb72e1414 in QTextEngine::justify (this=0x8486e60, line=@0x83b7920) at text/qtextengine.cpp:1804
#14 0xb72e81fd in alignLine (eng=0x8486e60, line=@0x83b7920) at text/qtextlayout.cpp:79
#15 0xb72e938b in QTextLine::cursorToX (this=0xbfbecac8, cursorPos=0xbfbecab4, edge=QTextLine::Leading) at text/qtextlayout.cpp:2063
#16 0xb72d8a9d in QTextLine::cursorToX (this=0xbfbecac8, cursorPos=0, edge=QTextLine::Leading) at ../../include/QtGui/../../src/gui/text/qtextlayout.h:210
#17 0xb7335cc8 in QTextCursorPrivate::setX (this=0x83a2308) at text/qtextcursor.cpp:135
#18 0xb7338bdf in QTextCursor::setPosition (this=0x89a9d40, pos=2287, m=QTextCursor::MoveAnchor) at text/qtextcursor.cpp:1070
#19 0xb73042cd in QTextDocument::undo (this=0x849be40, cursor=0x89a9d40) at text/qtextdocument.cpp:406
#20 0xb3a0781e in undo (this=0x831f938) at /home/tz/develop/kde/svn/koffice/plugins/textshape/TextTool.cpp:1352
#21 0xb76e1289 in QUndoCommand::undo (this=0x81add98) at util/qundostack.cpp:223
#22 0xb76e1c70 in QUndoStack::undo (this=0x816d348) at util/qundostack.cpp:657
#23 0xb76fbedc in QUndoStack::qt_metacall (this=0x816d348, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbfbecd0c) at .moc/debug-shared/moc_qundostack.cpp:98
#24 0xb7b12ac4 in KUndoStack::qt_metacall (this=0x816d348, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbfbecd0c) at /home/ko2/kdelibs-build/kdeui/kundostack.moc:57
#25 0xb6d1d635 in QMetaObject::activate (sender=0x816d580, from_signal_index=5, to_signal_index=6, argv=0xbfbecd0c) at kernel/qobject.cpp:3028
#26 0xb6d1d83e in QMetaObject::activate (sender=0x816d580, m=0xb77c2af8, from_local_signal_index=1, to_local_signal_index=2, argv=0xbfbecd0c) at kernel/qobject.cpp:3121
#27 0xb70beb16 in QAction::triggered (this=0x816d580, _t1=false) at .moc/debug-shared/moc_qaction.cpp:216
#28 0xb70c06b8 in QAction::activate (this=0x816d580, event=QAction::Trigger) at kernel/qaction.cpp:1125
#29 0xb70c0857 in QAction::event (this=0x816d580, e=0xbfbed124) at kernel/qaction.cpp:1044
#30 0xb70c68c5 in QApplicationPrivate::notify_helper (this=0x805afa0, receiver=0x816d580, e=0xbfbed124) at kernel/qapplication.cpp:3803
#31 0xb70c6bab in QApplication::notify (this=0xbfbedecc, receiver=0x816d580, e=0xbfbed124) at kernel/qapplication.cpp:3393
#32 0xb7a88ebb in KApplication::notify (this=0xbfbedecc, receiver=0x816d580, event=0xbfbed124) at /home/tz/develop/kde/svn/kdelibs/kdeui/kernel/kapplication.cpp:311
#33 0xb6d0870a in QCoreApplication::notifyInternal (this=0xbfbedecc, receiver=0x816d580, event=0xbfbed124) at kernel/qcoreapplication.cpp:583
#34 0xb70c353d in QCoreApplication::sendEvent (receiver=0x816d580, event=0xbfbed124) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:209
#35 0xb7106325 in QShortcutMap::dispatchEvent (this=0x805b03c, e=0xbfbed544) at kernel/qshortcutmap.cpp:771
#36 0xb7107364 in QShortcutMap::tryShortcutEvent (this=0x805b03c, w=0x89259c8, e=0xbfbed544) at kernel/qshortcutmap.cpp:362
#37 0xb70c6dc6 in QApplication::notify (this=0xbfbedecc, receiver=0x89259c8, e=0xbfbed544) at kernel/qapplication.cpp:3430
#38 0xb7a88ebb in KApplication::notify (this=0xbfbedecc, receiver=0x89259c8, event=0xbfbed544) at /home/tz/develop/kde/svn/kdelibs/kdeui/kernel/kapplication.cpp:311
#39 0xb6d0870a in QCoreApplication::notifyInternal (this=0xbfbedecc, receiver=0x89259c8, event=0xbfbed544) at kernel/qcoreapplication.cpp:583
#40 0xb70d279f in QCoreApplication::sendSpontaneousEvent (receiver=0x89259c8, event=0xbfbed544) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:212
#41 0xb71320ce in qt_sendSpontaneousEvent (receiver=0x89259c8, event=0xbfbed544) at kernel/qapplication_x11.cpp:4588
#42 0xb716c5b4 in QKeyMapper::sendKeyEvent (keyWidget=0x89259c8, grab=false, type=QEvent::KeyPress, code=90, modifiers=@0xbfbed6a8, text=@0xbfbed6dc, autorepeat=false, count=1, nativeScanCode=29, 
    nativeVirtualKey=122, nativeModifiers=4) at kernel/qkeymapper_x11.cpp:1652
#43 0xb716d921 in QKeyMapperPrivate::translateKeyEvent (this=0x807f710, keyWidget=0x89259c8, event=0xbfbedc2c, grab=false) at kernel/qkeymapper_x11.cpp:1623
#44 0xb71435af in QApplication::x11ProcessEvent (this=0xbfbedecc, event=0xbfbedc2c) at kernel/qapplication_x11.cpp:3053
#45 0xb716fe71 in x11EventSourceDispatch (s=0x805df20, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:142
#46 0xb67a1cc6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#47 0xb67a5083 in ?? () from /usr/lib/libglib-2.0.so.0
#48 0xb67a563e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#49 0xb6d37b8c in QEventDispatcherGlib::processEvents (this=0x805b0d8, flags=@0xbfbeddc4) at kernel/qeventdispatcher_glib.cpp:319
#50 0xb716f68c in QGuiEventDispatcherGlib::processEvents (this=0x805b0d8, flags=@0xbfbeddf4) at kernel/qguieventdispatcher_glib.cpp:198
#51 0xb6d055ca in QEventLoop::processEvents (this=0xbfbede70, flags=@0xbfbede34) at kernel/qeventloop.cpp:143
#52 0xb6d05809 in QEventLoop::exec (this=0xbfbede70, flags=@0xbfbede78) at kernel/qeventloop.cpp:190
#53 0xb6d08ef3 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:845
#54 0xb70c65de in QApplication::exec () at kernel/qapplication.cpp:3331
#55 0xb7fcde82 in kdemain (argc=1, argv=0xbfbedfc4) at /home/tz/develop/kde/svn/koffice/kword/part/main.cpp:38
#56 0x08048736 in main (argc=) at /home/ko2/koffice-build/kword/part/kword_dummy.cpp:3
Comment 1 Thomas Zander 2009-01-25 23:03:26 UTC

*** This bug has been marked as a duplicate of bug 175911 ***