Bug 181592 - add more useful information to file properties view panel (F11)
Summary: add more useful information to file properties view panel (F11)
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 183792 184466 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-22 15:01 UTC by Nadav Kavalerchik
Modified: 2009-02-17 21:37 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nadav Kavalerchik 2009-01-22 15:01:05 UTC
Version:           1.2 (using 4.1.96 (KDE 4.1.96 (KDE 4.2 RC1)), Debian packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.26-1-amd64

add more meta data into file properties view panel for movies and sound files
codec , size , duration, author...
Comment 1 Peter Penz 2009-01-22 15:27:52 UTC
We'll do, see also http://www.kdedevelopers.org/node/3843 for details :-)
Comment 2 Peter Penz 2009-02-09 17:22:42 UTC
*** Bug 183792 has been marked as a duplicate of this bug. ***
Comment 3 Peter Penz 2009-02-17 18:02:11 UTC
*** Bug 184466 has been marked as a duplicate of this bug. ***
Comment 4 Peter Penz 2009-02-17 21:37:36 UTC
SVN commit 927542 by ppenz:

* Use Nepomuk for getting the meta data instead of KFileMetaInfo.
* Use a QScrollArea widget to embedd the meta data, as Nepomuk provides so much meta information that it might not fit into the panel.

Open issues:
* Add the possibility to configure which kind of meta information should be shown.
* Check whether the receiving of the meta data for one file also might block the UI like when using KFileMetaInfo in combination with strigi.

CCMAIL: sebastian@trueg.de
BUG: 180742
BUG: 181592

 M  +46 -67    informationpanel.cpp  
 M  +6 -7      informationpanel.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=927542