Bug 181535 (icqproto-jan-2009) - cannot connect to server because protocol changed
Summary: cannot connect to server because protocol changed
Status: RESOLVED FIXED
Alias: icqproto-jan-2009
Product: kopete
Classification: Unclassified
Component: ICQ and AIM Plugins (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 181550 181601 181850 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-21 23:06 UTC by Andrew Belitsky
Modified: 2009-01-25 15:43 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Belitsky 2009-01-21 23:06:41 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

When I'm connecting to ICQ server I'm getting this mesage:

=============================
System Message
=============================
The version you are using is not supported by ICQ. Download a free authorized ICQ version from ICQ's official website.

and all users from my contact list keeps offline status.
Comment 1 Matt Rogers 2009-01-22 00:20:21 UTC
*** Bug 181550 has been marked as a duplicate of this bug. ***
Comment 2 Matt Rogers 2009-01-22 00:23:17 UTC
I was unable to reproduce this. I did not receive a message and all my contacts show online.
Comment 3 Alexey Chernov 2009-01-22 00:28:42 UTC
Perhaps, it's because AFAIK only russian provider's IPs were blocked. And also there're some servers remaining with older versions of protocol. But for me 3 times are enough to get such a message.
Comment 4 Roman Jarosz 2009-01-22 09:56:59 UTC
The fix is apparently already available (http://habrahabr.ru/blogs/im/49778/) but the source will be released today if google translator did good job :) When it's released I'll fix it ASAP. 
Comment 5 Alexey Chernov 2009-01-22 10:26:54 UTC
Well, i'm not the best translator in the world, but if google fails i can try to translate this post on habr.
Comment 6 Matt Rogers 2009-01-22 16:34:20 UTC
*** Bug 181601 has been marked as a duplicate of this bug. ***
Comment 7 Roman Jarosz 2009-01-22 18:38:18 UTC
I have a patch http://kedge.wz.cz/kopete/icqflacfix.diff which should fix this bug. I want to make the startSequences configurable in kopete.rc so I'll commit it to svn later (in 1 or 2 hours)
Comment 8 Roman Jarosz 2009-01-22 21:20:15 UTC
SVN commit 915334 by rjarosz:

Fix ICQ for CIS countries. Apparently ICQ decided that flac sequence number can't be random anymore.
Please test if there aren't any invalid flacs in the list.

Dirk please put this into KDE 4.2.0, thanks!

BUG: 181535
CCMAIL:mueller@kde.org



 M  +17 -2     liboscar/connection.cpp  
 M  +3 -1      liboscar/connection.h  
 M  +55 -0     oscarprotocol.cpp  
 M  +3 -3      oscarversionupdater.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915334
Comment 9 Roman Jarosz 2009-01-22 21:21:53 UTC
SVN commit 915335 by rjarosz:

Forwardport commit 915334.
Fix ICQ for CIS countries. Apparently ICQ decided that flac sequence number can't be random anymore.
Please test if there aren't any invalid flacs in the list.

CCBUG: 181535



 M  +17 -2     liboscar/connection.cpp  
 M  +3 -1      liboscar/connection.h  
 M  +55 -0     oscarprotocol.cpp  
 M  +3 -3      oscarversionupdater.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915335
Comment 10 Roman Jarosz 2009-01-22 21:22:32 UTC
SVN commit 915337 by rjarosz:

Backport commit 915334.
Fix ICQ for CIS countries. Apparently ICQ decided that flac sequence number can't be random anymore.
Please test if there aren't any invalid flacs in the list.

CCBUG: 181535



 M  +17 -2     liboscar/connection.cpp  
 M  +3 -1      liboscar/connection.h  
 M  +55 -0     oscarprotocol.cpp  
 M  +3 -3      oscarversionupdater.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915337
Comment 11 Alexey Chernov 2009-01-22 21:27:37 UTC
Thank you very much, Roman.
Unfortunately, AOL seemed to revert changes today, so it's nearly impossible to test changes, because kopete logs in even with older settings now.
But anyway, thanks a lot for your rapid work!
Comment 12 Dmitry Suzdalev 2009-01-22 21:30:26 UTC
Yeah, huge thanks, Roman!
Comment 13 Roman Jarosz 2009-01-25 14:21:19 UTC
*** Bug 181850 has been marked as a duplicate of this bug. ***
Comment 14 Roman Jarosz 2009-01-25 15:37:03 UTC
SVN commit 916552 by rjarosz:

Use algorithm which will randomly generate all valid start flac sequence number.
Code taken from Miranda. Sequence number were debugged against ICQ 6.5 (build 1005).
It's still possible to override it in kopeterc file.

CCBUG: 181535



 M  +15 -9     liboscar/connection.cpp  
 M  +3 -0      liboscar/connection.h  
 M  +3 -43     oscarprotocol.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=916552
Comment 15 Roman Jarosz 2009-01-25 15:38:22 UTC
SVN commit 916554 by rjarosz:

Backport commit 916552.
Use algorithm which will randomly generate all valid start flac sequence number.
Code taken from Miranda. Sequence number were debugged against ICQ 6.5 (build 1005).
It's still possible to override it in kopeterc file.

CCBUG: 181535


 M  +15 -9     liboscar/connection.cpp  
 M  +3 -0      liboscar/connection.h  
 M  +3 -43     oscarprotocol.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=916554
Comment 16 Roman Jarosz 2009-01-25 15:38:49 UTC
SVN commit 916555 by rjarosz:

Backport commit 916552.
Use algorithm which will randomly generate all valid start flac sequence number.
Code taken from Miranda. Sequence number were debugged against ICQ 6.5 (build 1005).
It's still possible to override it in kopeterc file.

CCBUG: 181535


 M  +15 -9     liboscar/connection.cpp  
 M  +3 -0      liboscar/connection.h  
 M  +3 -43     oscarprotocol.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=916555
Comment 17 Roman Jarosz 2009-01-25 15:43:57 UTC
In previous patch there probably shouldn't be these numbers? 0x0001, 0x04E7, 0x0B25, 0x163F, 0x2886, 0x5C44. But anyway you should use the new patch.