Bug 180646 - add "descending" checkbox for folderview plasmoid
Summary: add "descending" checkbox for folderview plasmoid
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-folderview (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 229599 234388 301797 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-14 12:21 UTC by Alexandre Pereira
Modified: 2012-09-10 10:31 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Pereira 2009-01-14 12:21:17 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

using kde 4.1.87

i would like to have folderview plasmoid to sort icon in order desc or asc ( descendent or ascent (bad spelling ? ))

usage example : to create a folderview of a folder where all my new download files go to. so on top it would always show the most recent files i downloaded.

thanks for the wonderfull desktop
Comment 1 Jakob Lehmann 2010-05-23 02:19:50 UTC
Possible in KDE SC 4.4!
Comment 2 Alexandre Pereira 2010-05-23 02:48:28 UTC
what tha hell ... no it isnt !!!!

please put it back as unfixed
Comment 3 Jakob Lehmann 2010-05-23 02:55:31 UTC
(In reply to comment #2)
> what tha hell ... no it isnt !!!!
> 
> please put it back as unfixed

Oh yes it is, rightclick your folderview, go to settings, go to display and under icons select "sort by date", there you go.
Comment 4 Alexandre Pereira 2010-05-23 05:36:11 UTC
this bug report has nothing to do with "sort by date".

it has to do with the possibility to sort by order : ascent or descent.

maybe i should have stressed that in the bug report
Comment 5 Jakob Lehmann 2010-05-23 05:51:14 UTC
> usage example : to create a folderview of a folder where all my new download
> files go to. so on top it would always show the most recent files i downloaded.

Thats what you wrote, "sort by date" provides exactly that. If you want the possibility to revert the order, I guess thats not possible as of now, so I'll change it back to "new".
Is that what you want? To take a order (say "sort by date") and then have a button "revert" to revert the order?
Comment 6 Alexandre Pereira 2010-05-23 05:59:34 UTC
currently , sort by date puts my new files at bottom.

the sort by date was just an example.

what is missing it the order -> asc or descent.

the sort  by date is just the example i find it the more usable.

yes , an order button or option "descent" like dolphin has for its sorting types.

thanks
Comment 7 Tako Schotanus 2010-05-23 12:52:58 UTC
@Jakob: in fact he wrote "to sort icon in order desc or asc". In fact I had put this bug on my watch list exactly for that reason because I wanted this as well :)

The use case: have a "Downloads" folder view on my desktop where the newest files are near the top (especially because I want it small, showing only a dozen files while my downloads folder easily holds hundreds of files)
Comment 8 Jakob Lehmann 2010-05-23 18:30:10 UTC
Sorry, my bad... At least this wish got some attention after over a year...
I believe a "descending" checkbox would be a good idea and this is a reasonable wish!
Good Luck :)
Comment 9 Alexandre Pereira 2010-05-24 02:49:46 UTC
no problem :)

thanks
Comment 10 Ignat Semenov 2012-02-02 22:05:06 UTC
*** Bug 234388 has been marked as a duplicate of this bug. ***
Comment 11 Ignat Semenov 2012-02-03 18:22:39 UTC
*** Bug 229599 has been marked as a duplicate of this bug. ***
Comment 12 Ignat Semenov 2012-02-04 08:20:47 UTC
Git commit e02b62d10c5ed46131204759b7f0f2722b540e99 by Ignat Semenov.
Committed on 03/02/2012 at 23:21.
Pushed by isemenov into branch 'master'.

Allow the user to choose between ascending and descending sort order.
FIXED-IN:4.9

M  +61   -4    plasma/applets/folderview/folderview.cpp
M  +3    -0    plasma/applets/folderview/folderview.h

http://commits.kde.org/kde-baseapps/e02b62d10c5ed46131204759b7f0f2722b540e99
Comment 13 Ignat Semenov 2012-02-07 21:40:34 UTC
Git commit 69bc39db131deadc3f430ef2c5fb8d411772276d by Ignat Semenov.
Committed on 07/02/2012 at 22:33.
Pushed by isemenov into branch 'master'.

give folders sorting precedence regardless of the sorting order used

When comparing folders wth other file items in ProxyModel::lessThan(), take into account the current sorting order to allow folders to get to the start of the list. Note that the folders are still sorted according to the current sorting order.
REVIEW:103884

M  +2    -2    plasma/applets/folderview/proxymodel.cpp

http://commits.kde.org/kde-baseapps/69bc39db131deadc3f430ef2c5fb8d411772276d
Comment 14 Ignat Semenov 2012-02-07 21:43:37 UTC
Git commit 74e44ad91b33268ef014cad32548d76517d848b1 by Ignat Semenov.
Committed on 07/02/2012 at 22:33.
Pushed by isemenov into branch 'KDE/4.8'.

give folders sorting precedence regardless of the sorting order used

When comparing folders wth other file items in ProxyModel::lessThan(), take into account the current sorting order to allow folders to get to the start of the list. Note that the folders are still sorted according to the current sorting order.
REVIEW:103884

M  +2    -2    plasma/applets/folderview/proxymodel.cpp

http://commits.kde.org/kde-baseapps/74e44ad91b33268ef014cad32548d76517d848b1
Comment 15 Janek Bevendorff 2012-06-14 08:55:38 UTC
*** Bug 301797 has been marked as a duplicate of this bug. ***
Comment 16 Alexandre Pereira 2012-06-14 15:31:08 UTC
I just installed 4.8.80 and it has that option to sort date DESC. 

THANKS !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :)
Comment 17 Dave Lepore 2012-06-20 20:30:51 UTC
hi, 
I have kde 4.8.90 but I can't see the option to set the descending order. When clicking to "Sorting" I have:
By Name
By Size
By Type
By Date

Am I doing something wrong?
Comment 18 Janek Bevendorff 2012-06-21 14:53:34 UTC
That option is not in the settings dialog, but you can right-click on the plasmoid and then choose Icons->Sort Icons->Descending.
It's a little unintuitive and maybe someone could add this to the settings dialog as well, but I would suggest you open a new report for that. But sorting in descending order is possible at least.
Comment 19 Dave Lepore 2012-06-21 19:16:31 UTC
I didn't see it because I have the plasmoid in a panel, and there the option does not show up even if you right click on the plasmoid. 

Fortunately, you can set the option while the plasmoid is on the desktop and it will remember when you move it into a panel.

I believe it would be nice to have the option directly form the panel, if possible.

Oh, and thank you very much for the reply :)
Comment 20 Gregor Petrin 2012-08-20 09:27:54 UTC
I do not agree with the Fixed resolution at all - the current method of having to pull the folder view to the desktop, right-click & hunt for the right option, then dragging it back is very counter intuitive! 

In fact, the only reason I found a way to do it was because I wanted to file a bug report and was looking for existing ones, I assume most people would simply give up.
Comment 21 Myriam Schweingruber 2012-09-08 11:23:52 UTC
(In reply to comment #20)
> I do not agree with the Fixed resolution at all - the current method of
> having to pull the folder view to the desktop, right-click & hunt for the
> right option, then dragging it back is very counter intuitive! 
> 
> In fact, the only reason I found a way to do it was because I wanted to file
> a bug report and was looking for existing ones, I assume most people would
> simply give up.

Then please file a wish for the desired changes.
Comment 22 Gregor Petrin 2012-09-10 10:31:26 UTC
Done: https://bugs.kde.org/show_bug.cgi?id=306537