Bug 180079 - Panels are completely hidden (and not accesible) after changing its settings from Auto-Hide to Always Visible
Summary: Panels are completely hidden (and not accesible) after changing its settings ...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: panel (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-09 00:00 UTC by Dario Andres
Modified: 2009-01-09 00:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dario Andres 2009-01-09 00:00:11 UTC
Version:           KDE: 4.2.60 (KDE 4.2.60 (KDE 4.3 >= 20090106)) kdelibs svn rev. 907834 / kdebase svn rev. 907837  (using Devel)
Compiler:          gcc 
OS:                Linux
Installed from:    Compiled sources

Here using:

Qt: 4.4.3 + qt-copy-patches-889120
KDE: 4.2.60 (KDE 4.2.60 (KDE 4.3 >= 20090106))
kdelibs svn rev. 907834 / kdebase svn rev. 907837
on ArchLinux x86_64 - Kernel 2.6.27.10
(using VESA drivers for testing)

Steps to reproduce:

You can use the default panel or a new one
- RMB click, Click on "Panel Settings"
- In "More Settings" set "Visibility" to "Auto hide"
- Close the settings.
- Move the mouse cursor to another position and the panel will hide.
Now you need to change the settings again
- Move the mouse cursor to the panel screen edge
The panel appears
- Click on "Panel Settings"
The black "configuration panel" appears, however the panel itself is now hidden
- In "More Settings" set "Visibility" to "Always Visible"
- Close the settings

The panel doesn't appear, plus, you can't access it anymore, (as it's no more an auto-hide).

If you do RMB in the place when the panel "is" you get the main containment (desktop/folderview) context menu. (so .. there is no panel)

The only way to display the panel again (and to get access to it) is to restart plasma (kquitapp plasma && plasma)
Comment 1 Aaron J. Seigo 2009-01-09 00:31:30 UTC
SVN commit 907949 by aseigo:

two bugs in one: ensure visibility and geometry on visibilityMode change, count the controller in hasPopup. i never noticed this one because like a sane person i use the panel cashew: i couldn't bother to right click, position properly, release or click again. mouse to the corner -> click -> win! so much easier.
BUG:180079


 M  +6 -1      panelview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=907949
Comment 2 Aaron J. Seigo 2009-01-09 00:34:10 UTC
SVN commit 907951 by aseigo:

backport fix for bug#180079
CCBUG:180079


 M  +6 -1      panelview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=907951