Bug 179945 - Ktorrent should recognise a torrent as incomplete when more files are selected
Summary: Ktorrent should recognise a torrent as incomplete when more files are selected
Status: RESOLVED FIXED
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
: 274313 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-07 20:25 UTC by piemonkey
Modified: 2011-05-28 12:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description piemonkey 2009-01-07 20:25:36 UTC
Version:           3.1.2 (using 4.1.3 (KDE 4.1.3), Kubuntu packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.27-9-generic

I like to set a maximum share ratio, so that once I have uploaded as much as I have downloaded, ktorrent stops the torrent, which frees up bandwidth for others.

This works fine, with only one slight catch, if I don't download all of the files in a torrent, and then seed until I get a share ratio of 1.0, it quite rightly stops the torrent. If I then tell it to download another one of the files, I have to manually start the torrent, and confirm that I want to seed beyond the maximum share ratio. Once the download has finished, it then continues to seed, beyond 1.0, until I manually stop it.
Comment 1 Giorgos Skafidas 2010-02-06 15:27:31 UTC
I can confirm that this is still an issue in version 4.0b1. I have to temporarily disable my ratio limit to get it to download the rest of the torrent.
Comment 2 Joris Guisson 2011-03-22 19:16:12 UTC
Git commit 1383e4908daf465e40caab21a16cfe16514b1263 by Joris.
Committed on 22/03/2011 at 19:17.
Pushed by guisson into branch 'master'.

Make sure a torrent is restarted when it was auto stopped and more files are selected for downloading

BUG: 179945

M  +1    -0    ChangeLog     
M  +6    -1    src/torrent/torrentcontrol.cpp     
M  +1    -0    src/torrent/torrentstats.cpp     
M  +2    -0    src/torrent/torrentstats.h     

http://commits.kde.org/libktorrent/1383e4908daf465e40caab21a16cfe16514b1263
Comment 3 Joris Guisson 2011-05-28 12:25:40 UTC
*** Bug 274313 has been marked as a duplicate of this bug. ***