Bug 179849 - add biblatex support in kile
Summary: add biblatex support in kile
Status: RESOLVED DUPLICATE of bug 268047
Alias: None
Product: kile
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
: 96281 120254 166757 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-06 22:18 UTC by Thomas Braun
Modified: 2012-08-29 11:29 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Braun 2009-01-06 22:18:07 UTC
Version:           2.0.4svn (using 3.5.10, Debian Package 4:3.5.10.dfsg.1-0lenny1 (lenny/sid))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.26-1-686

The following things are missing in kile to get complete support for biblatex (http://www.ctan.org/tex-archive/help/Catalogue/entries/biblatex.html) :
1.) biblatex.cwl file, maybe one for users and one for bibtex style file authors.
2.) codecompletion support for all citation commands including stuff like \cite[pre][post]{key}.
3.) support for automatic recompiling using REQ: lines in the latex log file. This would also enable refsection support.
4.) add biblatex file suffixes inside kile all other the place.
5.) syntax file updates to cover new citation commands.
Comment 1 Thomas Braun 2009-01-07 00:09:03 UTC
*** Bug 166757 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Braun 2009-01-08 22:18:32 UTC
*** Bug 120254 has been marked as a duplicate of this bug. ***
Comment 3 Thomas Braun 2009-02-16 00:01:16 UTC
5.) was done in r915126.
Comment 4 Thomas Braun 2009-05-27 00:19:12 UTC
*** Bug 96281 has been marked as a duplicate of this bug. ***
Comment 5 Thomas Braun 2009-08-19 13:38:01 UTC
SVN commit 1013244 by tbraun:

add biblatex file suffixes into latex.xml

CCBUG: 179849



 M  +1 -1      latex.xml  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1013244
Comment 6 Thomas Braun 2009-08-19 13:43:04 UTC
SVN commit 1013246 by tbraun:

add biblatex suffixes

CCBUG: 179849
so 4.) is now done

 M  +1 -1      kileextensions.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1013246
Comment 7 Thomas Braun 2009-08-19 21:43:50 UTC
SVN commit 1013406 by tbraun:

biblatex cwl files

BUG: 179849
1.) is now also done

 M  +1 -0      ChangeLog  
 A             src/data/complete/tex/biblatex-dev.cwl  
 A             src/data/complete/tex/biblatex.cwl  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1013406
Comment 8 Michel Ludwig 2012-08-29 11:29:33 UTC

*** This bug has been marked as a duplicate of bug 268047 ***