Bug 179237 - Dolphin FTP folders don't work well with non-anonymous FTP servers
Summary: Dolphin FTP folders don't work well with non-anonymous FTP servers
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: ftp (show other bugs)
Version: 4.1
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-31 21:13 UTC by Christopher Sawyer
Modified: 2011-03-23 19:10 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Sawyer 2008-12-31 21:13:10 UTC
Version:            (using KDE 4.1.3)
OS:                Linux
Installed from:    SuSE RPMs

Here is a video I made demonstrating the issue.

DivX/AVI format (17.7MB):
http://www.go-nfix.com/dolphin-ftp-problem.avi

Ogg-Video format for those of you who only believe in FOSS codecs (37.7MB):
http://www.go-nfix.com/dolphin-ftp-problem.ogv


I will leave these videos up until Feb-1-2009


Issues I have found:

1)  I have to manually remove the FTP port number from the URL bar in Dolphin to get Dolphin to connect to the FTP server

2)  I cannot copy or move any files to the FTP site although the account I am using has root privledges on the FTP server

3) I cannot create new folders on the FTP site through Dolphin.
Comment 1 FiNeX 2009-01-02 12:35:54 UTC
@Peter: I've addedd you on CC, maybe you could be interested too :-)
Comment 2 Russ Hay 2010-02-04 11:47:21 UTC
I can confirm this is still an issue with Dolphin version 1.4 in KDE 4.4.6.1

I'll get locked out of my FTP servers because Dolphin tries anonymous FTP despite having a login name/password specified.
Comment 3 Peter Penz 2011-03-23 19:10:18 UTC
Git commit c75f00df21d127b24a0e243eeeeaa075a8408cf9 by Peter Penz.
Committed on 23/03/2011 at 19:07.
Pushed by ppenz into branch 'master'.

KUrlNavigator: Don't use KIO::stat() for all non-local URLs

Doing a text-resolving with KIO::stat() for all non-local
URLs leads to problems for protocols where a limit is given for
the number of parallel connections.

BUG: 179237
BUG: 228345
BUG: 202097
FIXED-IN: 4.7.0

M  +16   -3    kfile/kurlnavigatorbutton.cpp     

http://commits.kde.org/kdelibs/c75f00df21d127b24a0e243eeeeaa075a8408cf9