Bug 177623 - If you play any audio file then closed Dragon, it won't play it again.
Summary: If you play any audio file then closed Dragon, it won't play it again.
Status: RESOLVED FIXED
Alias: None
Product: dragonplayer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dragon Player Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-12 20:58 UTC by Luis Augusto Fretes Cuevas
Modified: 2009-02-05 00:35 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Augusto Fretes Cuevas 2008-12-12 20:58:13 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

With videos is behaves similar, but instead the video plays without any sound, but that was already reported.

With audio files, it will play it perfectly the first time, but if I later try to play it again it just won't.

If I erase the dragonplayerrc, it works again, so I guessed the bug is related with the config file.

Hope it helps.
Comment 1 FiNeX 2008-12-13 12:22:14 UTC
I can confirm this behaviour using current trunk.
Comment 2 David Edmundson 2009-01-21 22:24:37 UTC
SVN commit 914836 by davidedmundson:

BUG:177623
BUG:165249
Check channel validity before setting audio channel.


 M  +7 -5      videoWindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=914836
Comment 3 David Edmundson 2009-02-05 00:35:27 UTC
SVN commit 921398 by davidedmundson:

Backport all the fixes made to Dragonplayer after 4.2.0
Same as trunk revision 918684 except "reset video settings" feature not backported as includes new translation

add a check for unistd.h to the buildsystem.
and include unistd.h in dragonplayer/src/app/videoWindow.cpp, for usleep.
Fixed crash when loading Video after using VideoSettings Dialog, and VideoSettings dialog now only accessible if 
playing a Video file
BUG:177623
BUG:165249
Check channel validity before setting audio channel.
BUG: 171301
Fixes bug 171301 by adding a "Restore defaults" button to video settings dialog and looking for the "valueChanged" 
signal instead of "sliderMoved" for the Vdeo settings slider, ensuring that it will recognise all movements, not 
just those caused by dragging with mouse
When track finished pushing "play" now restarts track
Support for additional MediaSource state 'empty'
BUG:163099 Video window sometimes doesn't resize when opening a file with a restore position.
Supress powermanager from sleeping when playing a file
Replace all references to CODEINE with DRAGONPLAYER
Remove unused code. Fixed compile warning
Implements TheStream::prettyTitle() and removes two unused signals statusMessage(const QString &) and
titleChanged(const QString &) (Now obsolete due to MediaObject::metaDataChanged())
Code tidy up by Paul B
Fix pause button in DragonPart
Enable position slider based on seekableChanged phonon signal
Fix compile
extra ';'
Revert dbus FileChanged signal broken in last commit
Fix compiler warning on inline consts
Remove all of custom Engine::State enum and replace with Phonon::State
General refactor of state changing 



 M  +4 -2      app/actions.cpp  
 M  +2 -2      app/actions.h  
 M  +2 -2      app/adjustSizeButton.h  
 M  +2 -2      app/discSelectionDialog.h  
 M  +3 -5      app/extern.h  
 M  +2 -2      app/fullScreenAction.h  
 M  +2 -2      app/fullScreenToolBarHandler.h  
 M  +2 -2      app/listView.cpp  
 M  +52 -22    app/mainWindow.cpp  
 M  +13 -4     app/mainWindow.h  
 M  +3 -7      app/part.cpp  
 M  +4 -4      app/part.h  
 M  +2 -2      app/partToolBar.h  
 M  +2 -2      app/playDialog.h  
 M  +5 -5      app/playlistFile.cpp  
 M  +2 -2      app/playlistFile.h  
 M  +22 -3     app/recentlyPlayedList.cpp  
 M  +21 -0     app/recentlyPlayedList.h  
 M  +99 -137   app/stateChange.cpp  
 M  +23 -3     app/theStream.cpp  
 M  +5 -4      app/theStream.h  
 M  +40 -72    app/videoWindow.cpp  
 M  +16 -11    app/videoWindow.h  
 M  +33 -47    codeine.h  
 M  +3 -3      dbus/playerDbusHandler.cpp  
 M  +2 -2      dbus/playerDbusHandler.h  
 M  +2 -2      dbus/rootDbusHandler.h  
 M  +3 -3      dbus/trackListDbusHandler.cpp  
 M  +2 -2      dbus/trackListDbusHandler.h  
 M  +10 -17    debug.h  
 M  +3 -3      messageBox.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=921398