Bug 176797 - change font then click "apply" button, it crashes. But fine when click "ok"
Summary: change font then click "apply" button, it crashes. But fine when click "ok"
Status: RESOLVED FIXED
Alias: None
Product: kompare
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kompare developers
URL:
Keywords:
: 179609 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-03 15:25 UTC by mqy
Modified: 2009-10-07 19:08 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mqy 2008-12-03 15:25:35 UTC
Version:           3.5.1 (using KDE 4.1.3)
Compiler:          gcc 4.3.2 distribute from ubuntu 8.10 repo
OS:                Linux
Installed from:    Ubuntu Packages

(1) In the "configure kcompare" popup dialog, change font to another such as monospace, then click the "apply" button.
Before crash, kcompare eats almost total CPU cycles and quit a few memory (causes swapping if the code base to be compared is a bit big).

(2) If click the "ok" button, it works fine.

NOTE: my locale is Chinese, so I can not tell you the exact the text shown on buttons and menu items. I'm sure you know where to open the dialog since kcompare is so simple as of configuration.
Comment 1 Jonathan Thomas 2008-12-24 02:13:48 UTC
I can confirm this with KDE 4.1.85. All one needs to do is open up the dialog and press apply.

Here is the related downstream bug: https://launchpad.net/bugs/303505
Comment 2 Kevin Kofler 2008-12-24 09:25:36 UTC
I can reproduce this on Fedora 9 (KDE 4.1.3). Hooray for infinite recursion... :-(
Comment 3 mqy 2008-12-24 16:21:10 UTC
Maybe another diff tool named "meld" is a temporary choice :)
It is written in Python, I installed it on Ubuntu 8.10 (Gnome desktop)
Comment 4 Kevin Kofler 2009-01-04 15:13:47 UTC
*** Bug 179609 has been marked as a duplicate of this bug. ***
Comment 5 Otto Bruggeman 2009-02-11 22:17:27 UTC
BUG: 176797 Fix infinite recursion. Winterz dont do this again please :D
Sending        kompare/komparepart/kompare_part.cpp
Sending        kompare/komparepart/kompareprefdlg.cpp
Sending        kompare/komparepart/kompareprefdlg.h
Transmitting file data ...
Committed revision 924880.
Comment 6 Kevin Kofler 2009-02-19 01:17:37 UTC
SVN commit 928150 by kkofler:

Mass backport of Kompare bugfixes for KDE 4.2.1 (should not touch any translatable strings): backport revisions 913308, 913309, 922431 (Kompare only), 924527, 924539, 924540, 924880, 924959, 924960, 925266, 926028, 926131, 926143, 926225, 928082 (minus i18n string changes), 928141, 928146 from trunk.
CCBUG: 176804
CCBUG: 169692
CCBUG: 182792
CCBUG: 176797
CCBUG: 175251
CCBUG: 75794
CCBUG: 89781
CCBUG: 145956
CCBUG: 107489
CCBUG: 165421
CCBUG: 174924
CCBUG: 103651
CCBUG: 102800
CCMAIL: bruggie@gmail.com

Bump Kompare version from 3.5.2 to 3.5.3 (trunk is 4.0.0).

Tested on Fedora 9 i386, KDE 4.2.0.

Note: skipped revision 926198 because it introduces a string and #124121 is more a user error than a bug anyway.

 M  +34 -30    kompare_shell.cpp  
 M  +18 -3     komparenavtreepart/komparenavtreepart.cpp  
 M  +15 -12    komparepart/kompare_part.cpp  
 M  +2 -2      komparepart/kompare_part.h  
 M  +9 -6      komparepart/kompareconnectwidget.cpp  
 M  +80 -31    komparepart/komparelistview.cpp  
 M  +26 -5     komparepart/komparelistview.h  
 M  +2 -2      komparepart/kompareprefdlg.cpp  
 M  +4 -1      komparepart/kompareprefdlg.h  
 M  +1 -1      komparepart/komparesplitter.cpp  
 M  +2 -1      libdialogpages/diffpage.cpp  
 M  +4 -3      libdialogpages/diffpage.h  
 M  +14 -4     libdialogpages/filespage.cpp  
 M  +4 -4      libdialogpages/filespage.h  
 M  +10 -8     libdiff2/difference.cpp  
 M  +5 -2      libdiff2/difference.h  
 M  +2 -1      libdiff2/diffhunk.cpp  
 M  +2 -2      libdiff2/diffhunk.h  
 M  +5 -30     libdiff2/diffmodel.cpp  
 M  +3 -6      libdiff2/diffmodel.h  
 M  +1 -1      libdiff2/diffmodellist.cpp  
 M  +4 -2      libdiff2/diffmodellist.h  
 M  +34 -31    libdiff2/komparemodellist.cpp  
 M  +3 -1      libdiff2/komparemodellist.h  
 M  +2 -1      libdiff2/kompareprocess.cpp  
 M  +53 -17    libdiff2/levenshteintable.cpp  
 M  +5 -1      libdiff2/parserbase.cpp  
 M  +21 -26    main.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=928150
Comment 7 Jeff Snyder 2009-10-07 19:08:17 UTC
SVN commit 1032378 by je4d:

merge bruggie's r924880 from trunk:
> Fix infinite recursion. Winterz dont do this again please :D

CCBUG: 176797



 M  +1 -1      kompare_part.cpp  
 M  +1 -1      kompareprefdlg.cpp  
 M  +3 -0      kompareprefdlg.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1032378