Bug 176496 - Scrollbar behavior on middle mouse button click
Summary: Scrollbar behavior on middle mouse button click
Status: RESOLVED FIXED
Alias: None
Product: unknown
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: David Johnson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-29 22:33 UTC by Pandu Rao
Modified: 2011-07-11 01:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pandu Rao 2008-11-29 22:33:14 UTC
Version:            (using KDE 4.1.3)
OS:                Linux
Installed from:    Debian testing/unstable Packages

In KDE3, clicking the middle mouse button on a point on the scrollbar would place the scroll handle under the mouse cursor.

In KDE4.1.3, such an MMB click produces no action. I notice that an RMB click on the scrollbar produces a menu with a scroll here option.

The KDE3 behavior was perfect. It was intuitive and was a big productivity enhancer. It enabled the user to easily jump many pages in either direction thus saving many left mouse button clicks.

Please restore the KDE3 behavior for the MMB click on the scrollbar.

Thanks,
Pandu
Comment 1 Thomas Lübking 2008-11-30 20:27:14 UTC
this behavior is style dependent, supported by kstyle and works with oxygen
which (widget) style (it's not kwin related at all, but i don't know which list to reassign to) do you use and is it shipped with KDE?
Comment 2 Dario Andres 2009-01-23 11:39:45 UTC
No news from the bug reporter, closing. Please reopen this bug report if you  can post more information about the bug (What widget style are you using?). Thanks :) 
Comment 3 sigma.zx 2009-08-04 23:14:36 UTC
The bug is present in the Phase and Windows styles.

Using 4.3 RC2.
Comment 4 Thomas Lübking 2009-08-04 23:48:23 UTC
As for Phase it's probably up to David whether he wants this.

The "windows" style is built into and part of Qt (i.e. you'd have to ask there)
as Windows afaik doesn't show this behaviour it's probably not a bug but a correct UI clone... unless you consider windows to be a bug... ;-P
Comment 5 sigma.zx 2009-08-05 00:33:05 UTC
In both these styles, incidentally, you can middle-click on slider widgets and it works. So there is at least an inconsistency.
Comment 6 Thomas Lübking 2009-08-05 00:53:05 UTC
Maybe, but -in case- it's a Qt one (and a different bug and one that would immediately be marked upstream, so don't try - head over to Qt's bugtracker if you want this to change) and i don't know what windows does with MMBs

that said, just wait - i'm pretty sure David will agree to change that, as there's hardly a good reason to do not (SH_ScrollBar_MiddleClickAbsolutePosition, btw. ;-)

And the windows style has... "other problems" than it's slider behaviour
(frankly: would you ever want to use it unless forced?!)
Comment 7 Christoph Feck 2011-07-11 01:57:29 UTC
SVN commit 1240902 by cfeck:

Respect MMB on scroll bars

BUG: 176496


 M  +3 -1      phasestyle.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1240902