Bug 176355 - Switching layout in kmail empties message list
Summary: Switching layout in kmail empties message list
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: commands and actions (show other bugs)
Version: unspecified
Platform: Compiled Sources Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Szymon Stefanek
URL:
Keywords:
: 176462 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-28 17:49 UTC by kgw
Modified: 2012-07-31 11:03 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kgw 2008-11-28 17:49:36 UTC
Version:            (using Devel)
Installed from:    Compiled sources

When you change the setting "show favourite folder view" in the settings/layout the message list gets emptied and will only be populated again by klicking on a different message folder.
Messages are not lost but sometimes the column width on the message list resets so that only the date column occupies the window and the only way to reset that is by having all columns resized automatically using the context menu.
Comment 1 Martin Koller 2009-08-20 00:04:07 UTC
*** Bug 176462 has been marked as a duplicate of this bug. ***
Comment 2 Oliver Putz 2009-08-20 10:06:15 UTC
Confirming as still reproducible with KDE-4.3.0
Comment 3 Laurent Montel 2011-09-08 10:31:36 UTC
Still valid in 4.8 will look at it
Comment 4 Laurent Montel 2012-07-31 11:03:29 UTC
Git commit c3bb265ebd34b14fa3ffe51d04d07f42ad895e01 by Montel Laurent.
Committed on 31/07/2012 at 11:31.
Pushed by mlaurent into branch 'KDE/4.9'.

Fix Bug 176355 - Switching layout in kmail empties message list

We restore current selected folder now.

FIXED-IN: 4.9.1

M  +14   -5    kmail/kmmainwidget.cpp
M  +1    -1    kmail/kmmainwidget.h

http://commits.kde.org/kdepim/c3bb265ebd34b14fa3ffe51d04d07f42ad895e01