Bug 172899 - Verbiage changes for digikamapp.cpp
Summary: Verbiage changes for digikamapp.cpp
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Usability-i18n (show other bugs)
Version: unspecified
Platform: Compiled Sources Unspecified
: NOR wishlist
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-15 21:59 UTC by Joe Biden
Modified: 2017-08-05 07:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 0.10.0


Attachments
Helping with the skills I have to clear up the English used. (8.99 KB, patch)
2008-10-15 22:00 UTC, Joe Biden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Biden 2008-10-15 21:59:50 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Add/change a lot of smaller items in the main app.
Comment 1 Joe Biden 2008-10-15 22:00:24 UTC
Created attachment 27922 [details]
Helping with the skills I have to clear up the English used.
Comment 2 Andi Clemens 2008-10-16 01:20:41 UTC
Some questions:

     d->refreshAlbumAction = new KAction(KIcon("view-refresh"), i18n("Refresh"), this);
     d->refreshAlbumAction->setShortcut(Qt::Key_F5);
-    d->refreshAlbumAction->setWhatsThis(i18n("Refresh all album contents."));
+    d->refreshAlbumAction->setWhatsThis(i18n("Refresh the contents of all albums."));
     connect(d->refreshAlbumAction, SIGNAL(triggered()), d->view, SLOT(slotAlbumRefresh()));
     actionCollection()->addAction("album_refresh", d->refreshAlbumAction);


I guess this is wrong, since the refresh action is not working on all albums, only on the current one.





-    d->zoomTo100percents = new KAction(KIcon("zoom-original"), i18n("Zoom to 1:1"), this);
+    d->zoomTo100percents = new KAction(KIcon("zoom-original"), i18n("Zoom to Full"), this);
     d->zoomTo100percents->setShortcut(Qt::ALT+Qt::CTRL+Qt::Key_0);       // NOTE: Photoshop 7 use ALT+CTRL+0
     connect(d->zoomTo100percents, SIGNAL(triggered()), d->view, SLOT(slotZoomTo100Percents()));
     actionCollection()->addAction("album_zoomto100percents", d->zoomTo100percents);


I think we should keep it the way it is, this is a common term (or we could use "actual size" like in gwenview.




-    d->libsInfoAction = new KAction(KIcon("help-about"), i18n("Components info"), this);
+    d->libsInfoAction = new KAction(KIcon("help-about"), i18n("Component info"), this);
     connect(d->libsInfoAction, SIGNAL(triggered()), this, SLOT(slotComponentsInfo()));
     actionCollection()->addAction("help_librariesinfo", d->libsInfoAction);


Isn't there a plural for components? This dialog shows information for all used components, not only one.




-    d->cameraSolidMenu->menuAction()->setText(i18n("Digital Cameras"));
+    d->cameraSolidMenu->menuAction()->setText(i18n("Cameras (Auto-detected)"));
     d->cameraSolidMenu->menuAction()->setIcon(KIcon("camera-photo"));
     d->usbMediaMenu->menuAction()->setText(i18n("USB Storage Devices"));
     d->usbMediaMenu->menuAction()->setIcon(KIcon("drive-removable-media-usb"));
     d->cardReaderMenu->menuAction()->setText(i18n("Card Readers"));
     d->cardReaderMenu->menuAction()->setIcon(KIcon("media-flash-smart-media"));
-    d->manuallyAddedCamerasMenu->menuAction()->setText(i18n("Cameras Added Manually"));
+    d->manuallyAddedCamerasMenu->menuAction()->setText(i18n("Cameras (Add)"));
     d->manuallyAddedCamerasMenu->menuAction()->setIcon(KIcon("preferences-other"));


The first one is ok I think (not yet merged though in my branch), but the second might be wrong. This menu entry will list all manually added cameras, now it sounds like you can only add cameras here (which can of course, but it sounds more like an action now).




                 driveType = i18n("SD / MMC Card Reader");
                 break;
             case Solid::StorageDrive::Xd:
-                driveType = i18n("xD-Picture Card Reader");
+                driveType = i18n("xD Card Reader");
                 break;


The medium is called that way, but maybe a reading device is named differently? I don't actually know (http://en.wikipedia.org/wiki/XD-Picture_Card)




-    QString msg = i18n("Image finger-prints computation can take a while.\n"
-                       "What do you want to do?\n"
-                       "- Scan for changed or non-recorded items in database\n"
-                       "- Rebuild all fingerprints (long)");
+    QString msg = i18n("The initial image fingerprinting can take some time.\n"
+                       "Which would you prefer?\n"
+                       "- Scan for changed or non-cataloged items in the database (quick)\n"
+                       "- Rebuild all fingerprints (takes a long time)");


This dialog will appear not only on first digiKam start, but every time when you hit "rebuild fingerprints". So I guess initial is a wrong term here?




Again, this sounds like a lot of criticism, but it's not meant that way :-)
I appreciate your work, but sometimes I'm not quite sure about some phrases.

Gilles,

what do you think?

Andi
Comment 3 Mikolaj Machowski 2008-10-16 15:25:44 UTC
Ad 1:1 controversy

Maybe zoom to 100%? 100% is the most used term.

Ad xD

Shorter is better. xD Picture Card may be official name but we don't have to be overcorrect.
Comment 4 Andi Clemens 2008-10-16 15:52:24 UTC
I've already merged xD short version...
About 1:1 (100%):
Is there a GUI guide somewhere describing what to use? Gwenview uses "Actual Size" now, but the old version was "1:1" if I remember correctly.
Comment 5 Andi Clemens 2008-10-16 16:29:10 UTC
SVN commit 872187 by aclemens:

A small series of patches that fix a few english phrases
(thanks to Brendan Barry)

BUG:172882
BUG:172884
BUG:172892
BUG:172895
BUG:172898
BUG:172899

 M  +23 -23    digikam/digikamapp.cpp  
 M  +24 -25    digikam/digikamfirstrun.cpp  
 M  +15 -15    showfoto/setup/setupeditor.cpp  
 M  +8 -8      tips  
 M  +7 -8      utilities/imageeditor/tools/imageresize.cpp  
 M  +1 -1      utilities/setup/setup.cpp  
 M  +1 -2      utilities/setup/setupalbumview.cpp  
 M  +18 -18    utilities/setup/setupcollections.cpp  
 M  +7 -7      utilities/setup/setupmetadata.cpp  
 M  +44 -32    utilities/setup/setupmime.cpp  
 M  +3 -3      utilities/setup/setupmisc.cpp  
 M  +60 -60    utilities/setup/setupslideshow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=872187
Comment 6 Andi Clemens 2008-10-21 22:47:27 UTC
SVN commit 874580 by aclemens:

sync new action name with imageeditor and showFoto

CCBUG:172899

 M  +1 -1      imageeditor/editor/editorwindow.cpp  
 M  +1 -1      lighttable/lighttablewindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=874580