Bug 172334 - JS-expanding page tree on SAP help page doesn't work
Summary: JS-expanding page tree on SAP help page doesn't work
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: 4.1.2
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL: http://help.sap.com/saphelp_erp2005vp...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-07 14:17 UTC by Jakob Petsovits
Modified: 2021-03-21 03:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jakob Petsovits 2008-10-07 14:17:48 UTC
Don't ask why I'm lurking around there, because I'm not. Anyways.

Steps to reproduce:
1. Go to http://help.sap.com/saphelp_erp2005vp/helpdata/en/6c/c9b54015c4752ae10000000a155106/frameset.htm
2. Press the [+] button next to "Recruitment" or "Succession Planning". The book does not expand, neither does the "Expand All" button. Navigation is futile.
3. Open Firefox 3.0.3 instead and browse through the book contents. (optional step.)
Comment 1 Maksim Orlovich 2008-10-07 15:28:16 UTC
Seems to rely on window.scrollbars, probably a Gecko extension:
http://developer.mozilla.org/en/DOM/window.scrollbars

Easy enough to add as readonly...
Comment 2 Harri Porten 2008-10-08 03:29:06 UTC
There's a preliminary fix checked in that makes the menu work. Thanks for the report!

I'll leave this report still open as a reminder as the emulation of the object in question is not complete, yet.
Comment 3 David Heijkamp 2011-01-06 22:24:58 UTC
The referred webpage doesn't exist anymore. Not able to reproduce the problem.
Comment 4 Justin Zobel 2021-03-21 00:24:55 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 10 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 5 Jakob Petsovits 2021-03-21 03:51:55 UTC
The referred webpage doesn't exist anymore and redirects elsewhere. I have also stopped using Konqueror, nowadays it's Firefox that has to battle against irrelevance. Times have indeed changed, haven't they. Thanks and cheers!