Bug 172159 - rsibreak doesn't show the systray screenshot properly
Summary: rsibreak doesn't show the systray screenshot properly
Status: RESOLVED FIXED
Alias: None
Product: rsibreak
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Tom Albers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-04 20:55 UTC by Zdeněk Zikán
Modified: 2008-10-25 01:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of improperly rendered panel (48.33 KB, image/png)
2008-10-04 20:56 UTC, Zdeněk Zikán
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zdeněk Zikán 2008-10-04 20:55:23 UTC
Version:           0.9.0 beta3 (using KDE 4.1.2)
OS:                Linux
Installed from:    Ubuntu Packages

When rsibreak is run for the first time, it takes screenshot of the systray to show user where to look for its icon. However, in KDE4 panel, it takes the screenshot during systray slow rendering.
See screenshot on http://www.fi.muni.cz/~xzikan/rsibreak-systray.png

I don't know whether it should be considered rsibreak or rather plasma bug, so I file it as rsibreak.
Comment 1 Zdeněk Zikán 2008-10-04 20:56:15 UTC
Created attachment 27685 [details]
screenshot of improperly rendered panel
Comment 2 Tom Albers 2008-10-25 01:09:21 UTC
SVN commit 875627 by toma:

Delay the welcome screen for a second. This makes it work for me. We need to change it back as soon as there is a fast implementation of the systray where icons appear instantly.
BUG: 172159


 M  +1 -1      rsiwidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=875627