Bug 171896 - maps on maps.google.it not showed correctly
Summary: maps on maps.google.it not showed correctly
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: 4.1.1
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 173233 179278 179725 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-30 11:11 UTC by Andrea Iacovitti
Modified: 2009-01-05 16:17 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kde 3.5.9 patch (2.03 KB, patch)
2008-10-09 21:38 UTC, Andrea Iacovitti
Details
Screenshot showing that the bug has returned in Nov 2008 (82.44 KB, image/png)
2008-11-24 08:18 UTC, Toby Newman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrea Iacovitti 2008-09-30 11:11:06 UTC
Version:            (using KDE 4.1.1)
OS:                Linux
Installed from:    Debian testing/unstable Packages

Somethings has changed in google maps.... about 2 weeks ago this map was rendered correctly on konqueror: http://maps.google.it/maps/ms?msa=0&msid=113892361580153724361.000453dddab052c84972f

Now the map image is shrinked.
Comment 1 Raúl 2008-10-03 00:21:50 UTC
Same problem here on konqueror 4.1.2 (Debian unstable/experimental) and on konqueror 3.5.9 (Debian unstable).

Indeed bets are that google changed anything while they cowardly are not supporting konqueror browser natively.

Regards,
Comment 2 Maksim Orlovich 2008-10-03 01:31:07 UTC
Thanks for the result, confirm. Weird.
Comment 3 Andrea Iacovitti 2008-10-05 18:13:21 UTC
If you save a local copy of the page either with Konqueror (tools->archive web page, .war file as result) or with firefox and then you open the local copies with konqueror both works (map window not shrunk ) ....well the .war archive copy shows the subimages that compose the map in the wrong order but the window map have the right size.
Another case of different behaviour between "online copy" and "local copy", like in bug #153745 .
Hope will help.

Comment 4 Andrea Iacovitti 2008-10-09 21:38:59 UTC
Created attachment 27769 [details]
kde 3.5.9 patch

Upstream revision #869318 solves the problem for kde4. The attached patch for kde 3.5.9/10
Comment 5 Tommi Tervo 2008-10-21 15:52:41 UTC
*** Bug 173233 has been marked as a duplicate of this bug. ***
Comment 6 Maksim Orlovich 2008-10-21 16:01:20 UTC
vtokarev fixed this...
Comment 7 Toby Newman 2008-11-24 08:18:08 UTC
Created attachment 28787 [details]
Screenshot showing that the bug has returned in Nov 2008

This bug is back in Konqueror 4.1.2.
Comment 8 Andrea Iacovitti 2008-11-24 09:59:01 UTC
This bug has been fixed in kde 4.1.3, see http://www.kde.org/announcements/changelogs/changelog4_1_2to4_1_3.php
Comment 9 Pino Toscano 2009-01-05 16:16:33 UTC
*** Bug 179725 has been marked as a duplicate of this bug. ***
Comment 10 Pino Toscano 2009-01-05 16:17:06 UTC
*** Bug 179278 has been marked as a duplicate of this bug. ***