Bug 171054 - auto-generate the .kdev4 file if the template doesn't have one
Summary: auto-generate the .kdev4 file if the template doesn't have one
Status: RESOLVED FIXED
Alias: None
Product: kdevplatform
Classification: Unclassified
Component: appwizard (show other bugs)
Version: 1.0.0
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
: 166547 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-14 16:43 UTC by Andreas Pakulat
Modified: 2009-01-22 23:38 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Pakulat 2008-09-14 16:43:14 UTC
the template format is shared between kdevelop and kapptemplate, but the latter doesn't provide .kdev4 files in its templates. Hence the appwizard should auto-generate them for templates where they are missing.
Comment 1 Andreas Pakulat 2008-11-03 20:00:55 UTC
*** Bug 166547 has been marked as a duplicate of this bug. ***
Comment 2 Khalil Moriello 2009-01-22 09:42:37 UTC
The same happens to me but kapptemplate neither creates a kdev4 template.
Comment 3 Andreas Pakulat 2009-01-22 10:43:43 UTC
This is actually already implemented, but I just tried and it didn't work. Seems like some bit got missing again. I'll have a look later today, fix will be included in the beta release we're going to do soon.
Comment 4 Andreas Pakulat 2009-01-22 21:59:39 UTC
SVN commit 915351 by apaku:

Implement a basic .kdev4 file writing. This obviously is just a
workaround until we have a better method in place.
BUG:171054

 M  +30 -2     appwizardplugin.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915351