Bug 169106 - Rendering glitches for dialog, windows, contexts etc.
Summary: Rendering glitches for dialog, windows, contexts etc.
Status: RESOLVED DUPLICATE of bug 170462
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-14 10:13 UTC by Frank Sagurna
Modified: 2008-12-21 16:13 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Picture of the graphic glitches (89.88 KB, image/jpeg)
2008-08-14 20:33 UTC, Frank Sagurna
Details
Screenshot of the glitches with kick-off (244.40 KB, image/png)
2008-10-12 16:37 UTC, Niels Slot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Sagurna 2008-08-14 10:13:44 UTC
Version:            (using KDE 4.1.0)
Installed from:    Ubuntu Packages
OS:                Linux

In KDE 4.1 (in 4.0 was the same), on displaying a new window/context menu/plasma widget, for about half a second up to a second the rendering of that object looks really ugly, like stripes on black background (differs, so not easy to explain, and not easy to get a screenshot because of the short time, but i will try)
Compositing is turned on, and happens on nvidia and intel graphics card.
Comment 1 Frank Sagurna 2008-08-14 20:33:06 UTC
Created attachment 26851 [details]
Picture of the graphic glitches

This is a picture with example dialog rendered incorrect.
As additional description: This is on a dualsreen setup, so i included a little
of the right screen, as it seems that some of this is visible in the dialog.
But this also happens on my laptop with intel graphics and no dualview. 
It just happens under KDE4, not in KDE3, and on ubuntu hardy 32bit and ubuntu
intrepid 64bit.
Comment 2 Frank Sagurna 2008-08-15 16:24:07 UTC
Addition:
I tried every combination of "direct rendering", "vsync" (In advanced desktop effects preferences), no change.
Comment 3 Niels Slot 2008-10-12 16:34:45 UTC
I've seen the same running intrepid or hardy packages on systems with intel, nvidia, ati or vmware graphics. There seems to be no difference whether to enable or disable compositing.

I'm only seeing this on Kubuntu. OpenSuse and Fedora are running fine (on the same hardware).
Comment 4 Niels Slot 2008-10-12 16:37:35 UTC
Created attachment 27830 [details]
Screenshot of the glitches with kick-off

I'm seeing this for 0.5 seconds when I open the kick-off menu for the first time in a session. The second time goes ok.
Comment 5 FiNeX 2008-11-30 18:58:05 UTC
I see this glitches everyday even using trunk :-(

Maybe kdelibs guys can know why :-)
Comment 6 Urs Wolfer 2008-11-30 19:07:42 UTC
I think these issues are releated to compositing.
Comment 7 David Nadlinger 2008-11-30 19:38:24 UTC
Martin Gräßlin was/is working on a solution (see the discussion on the kwin ML), but it seemed like using the latest nVidia beta driver solved the problem. Even if you do not like to use beta drivers, it might be worth a try, especially if you also experience the problems with compositing turned off.

I cannot say anything about Intel graphics cards though because I do not have access to one.

Can you please also try the latest version from SVN to see if the glitches still occur?

*** This bug has been marked as a duplicate of bug 170462 ***
Comment 8 Yves Glodt 2008-11-30 23:37:50 UTC
(In reply to comment #6)
> I think these issues are releated to compositing.

I see them without using compositing
Comment 9 Frank Sagurna 2008-12-21 16:13:46 UTC

*** This bug has been marked as a duplicate of bug 170462 ***