Bug 167861 - Right clicking a selection of multiple tracks in the playlist undoes the selection
Summary: Right clicking a selection of multiple tracks in the playlist undoes the sele...
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Playlist (show other bugs)
Version: 2.0-SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-31 17:18 UTC by Maarten Wisse
Modified: 2009-12-09 11:28 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten Wisse 2008-07-31 17:18:37 UTC
Version:           2.0-SVN (using KDE 4.1.0)
Installed from:    Compiled From Sources
Compiler:          gcc 4.1.2 
OS:                Linux

Ctrl-leftclick several tracks in the playlist.
The become selected
Rightclick one of the selected tracks, for example because you want to drop them from the playlist.
The selection will be undone. Only the rightclicked track will be selected.

However, dropping multiple tracks from playlist works, because if you press the 'Del'-key after selecting  multiple tracks, the tracks are removed from the playlist.
Comment 1 Maarten Wisse 2008-07-31 17:19:27 UTC
sorry, forgot to add the svn-version. It is from July 31, 2008, svn-revision 840128.
Comment 2 Mikko C. 2008-08-01 09:07:58 UTC
I can confirm this
Comment 3 Lydia Pintscher 2008-08-01 10:31:19 UTC
Confirming based on Mikko's comment.
Comment 4 Soren Harward 2008-09-23 16:47:10 UTC
The reason the rest of the selection is lost is because as of right now (r863918), the context menu cannot handle a multiple-track selection.  I'm working on a fix, but it's definitely non-trivial so I would suggest delaying the bug target to beta3 or later.
Comment 5 Soren Harward 2008-09-24 18:50:32 UTC
This wasn't quite as painful as I was afraid it was going to be.  Fixed in r864385.  The TagDialog still needs a little work, but the bugs are already marked AMAROK_NOTIMPLEMENTED and will be fixed with a different commit.
Comment 6 Mikko C. 2008-09-25 11:48:31 UTC
Not fixed for me.
Revision: 864615
Comment 7 Edward Hades 2008-09-25 13:39:46 UTC
Reopening according to Mikko's comment.
Comment 8 Mikko C. 2008-09-25 14:48:29 UTC
Ok, I understand now.
It works only if I don't release Shift/Ctrl before right-clicking.

What I usually do is: select the tracks with Shift/Ctrl -> release Shift/Ctrl -> right-click: this way it doesn't work.

I would say it's "half solved" :)
Comment 9 Mark Kretschmann 2008-10-08 15:28:18 UTC
Fixed with Soren's new playlist code.