Bug 167751 - Printing jounral entries with richtext from korganizer print html-tags
Summary: Printing jounral entries with richtext from korganizer print html-tags
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Unclassified
Component: printing (show other bugs)
Version: SVN trunk (KDE 4)
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 169074 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-30 16:52 UTC by gmud
Modified: 2009-01-08 22:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Example of "tagged" printout (49.49 KB, image/png)
2008-07-30 16:59 UTC, gmud
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gmud 2008-07-30 16:52:08 UTC
Version:           4.1.0 (using 4.1.00 (KDE 4.1.0), Kubuntu packages)
Compiler:          gcc
OS:                Linux (i686) release 2.6.24-19-rt

Steps to reproduce:

1. Create a new journalentry
2. Mark the "Rich text" box
3. Type something with bold, italic etc. formatting
4. Save entry
5. Print journalentry

Results:
The printed Page contains HTML-tags instead of formatted text

Expected results:
Don't print tags but formatted text
Comment 1 gmud 2008-07-30 16:59:30 UTC
Created attachment 26504 [details]
Example of "tagged" printout
Comment 2 Allen Winter 2008-08-15 16:44:44 UTC
*** Bug 169074 has been marked as a duplicate of this bug. ***
Comment 3 Christophe Giboudeaux 2008-12-06 01:33:28 UTC
The bug still exists in trunk (rev. 839007).
Comment 4 Ron Goodheart 2009-01-08 22:16:08 UTC
SVN commit 907451 by rgoodheart:

These changes also address some print overflow issues that were still
happening but were not reported.

GUI:
       gui changes to configuration dialogs

BUG: 102473
       Print month does not produce color output - events now in category
colors
BUG: 144809
       Calendar will not print in color - category colors for
incidence,day,week and month
BUG: 102598
       Print Locations,Descriptions, etc. on Filofax week pages - additional
info added
BUG: 104731
       include date when printing month view on paper - date now printed on
the bottom of page
BUG: 167751
       Printing jounral entries with richtext from korganizer print html-tags
       rich text is converted to plain text before printing for now on all
print types rather than printing the html

FEATURE: 71908
       calendar-print: option to switch on lines would be great - added
optional note lines
FEATURE: 83689
       Support printing of arbitrary date ranges - day range supports
arbitrary range
       (patch from David Faure incorporated  - feature in day print to print
selected range on one page
FEATURE: 110690
       Print "Month view" does not print all events - triangle printed in
lower right hand side of display box if the print overflows the box and all
information is not displayed



 M  +164 -114  calprintdayconfig_base.ui
 M  +96 -31    calprintdefaultplugins.cpp
 M  +9 -0      calprintdefaultplugins.h
 M  +95 -90    calprintincidenceconfig_base.ui
 M  +48 -18    calprintmonthconfig_base.ui
 M  +248 -106  calprintpluginbase.cpp
 M  +45 -6     calprintpluginbase.h
 M  +41 -13    calprinttodoconfig_base.ui
 M  +50 -34    calprintweekconfig_base.ui

WebSVN link: http://websvn.kde.org/?view=rev&revision=907451