Bug 167346 - Text in subject line is always black
Summary: Text in subject line is always black
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: composer (show other bugs)
Version: 1.10.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-24 11:44 UTC by Peter Lewis
Modified: 2008-07-25 16:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Lewis 2008-07-24 11:44:06 UTC
Version:           1.10.0 (using KDE 4.0.98)
Installed from:    Ubuntu Packages

In KMail 1.10.0 (KDE 4.1 RC1), in the composer window of KMail, the text colour is always black in the subject line.

If you're using a colour scheme with a black (or dark) background, this makes the text completely unreadable. The to/cc/bcc lines are for some reason given a white background regardless of the colour scheme, but the text colour is also set. The main body of the email obeys KMail's colour settings.

This is pretty important IMO, as the subject of an email is completely unreadable using some colour schemes.

Thanks.
Comment 1 Thomas McGuire 2008-07-24 23:19:20 UTC
I can't reproduce it, for me it uses the KDE colorscheme (white on black). Do you have custom colors enabled in the config?
Comment 2 Peter Lewis 2008-07-24 23:26:04 UTC
Hmmm... yes I do actually. But there doesn't seem to be anywhere in the custom colours configuration options to change it.
Comment 3 Thomas McGuire 2008-07-25 00:02:12 UTC
Right, configuring the text foreground color is not possible (it is "normal text" I think, but the setting doesn't take effect), and I wasn't able to fix that by looking at the issue for a few minutes.
I'm actually thinking of removing the color options altogether, I don't see why they would be needed when there is a KDE color scheme. I'm curious what you need custom colors for and why the KDE color scheme is not enough for you.
Comment 4 Peter Lewis 2008-07-25 00:59:43 UTC
Hmm... well I've always found the custom colours in KMail really useful. I guess my main reason is to make the application more usable with different KDE colour schemes. Specifically, I usually change the following to suit the colour scheme I have:

1) colours for different message statuses in the message list (i.e. unread, new, important, action item etc). If you choose a KDE colour scheme which uses a colour similar to one of the default message colours, it's hard to see it. Obviously, if they were hard-coded, then this would not be good. Perhaps this will also be important with message tagging too.

2) The same goes for the colours used for hyperlinks and quoted text in messages.

3) The colours used in messages to represent the various "signed" and "encrypted" wrappers also need to be adjusted to fit whichever colour scheme you choose.

I hope this some insight - please don't remove the custom colour functionality without considering these cases :-)

Though if this was somehow to be worked into the general KDE colour scheme settings system, then that's obviously fine too. I notice it's improved since 3.5.9.

Thanks.

PS. If you want more info, I'm happy to provide a few screenshots.
Comment 5 Thomas McGuire 2008-07-25 12:51:58 UTC
OK, I see your points, those color configs you mentioned should indeed stay.
The proper solution would of course be to calculate colors for the things you mentioned based on the color scheme, to give good contrast, but that is probably not easy to do and not 100% foolproof.

Now that I look at it, I would only remove the following:

- Background / Alternative Background color: These change the background of the list views and the composer fields. Since these can already changed by the KDE color scheme, I see no reason to keep them (plus they are buggy, for example the background of the message structure viewer is not changed).

- Normal Text: Same here, it changes the text color of the composer (doesn't work for the subject field right now, another bug) and the list views, but that is already provided by the color scheme as well.

This would also probably solve your problem: Since the subject line wouldn't have custom colors anymore, it would just work fine, since it uses the KDE colors then.

What do you think about this?
Comment 6 Peter Lewis 2008-07-25 15:01:15 UTC
I think that sounds quite sensible, yes, since the items you mention are basically a duplication of functionality. I can see why you'd want to remove that kind of thing.

Thanks for considering this - I'm colour blind so I find it quite important to be able to adjust colours in order to make my desktop more usable. For example, I don't like having red and green message wrappers, since they look very similar to me. I doubt that any "automatic" calculation of colours would be able to account for the many different types of colour blindness which exist, so I think it's good to keep the option to choose your own colours there.
Comment 7 Thomas McGuire 2008-07-25 16:36:16 UTC
SVN commit 837712 by tmcguire:

Remove the ability to set custom background and foreground colors.
Reasons:
- It was buggy (the recipientseditor, mimeparttree etc didn't obey to it)
- It is already provided by the KDE colorscheme (unlike the other color options)

Also, the ApplicationPaletteChange event is no longer used, so listen to
PaletteChange events instead.

BUG:102906
BUG:167346


 M  +1 -7      configuredialog.cpp  
 M  +2 -4      csshelper.cpp  
 M  +3 -7      favoritefolderview.cpp  
 M  +1 -11     foldertreebase.cpp  
 M  +0 -6      kmail.kcfg  
 M  +1 -45     kmcomposewin.cpp  
 M  +0 -10     kmcomposewin.h  
 M  +1 -18     kmheaders.cpp  
 M  +1 -1      kmreaderwin.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=837712