Bug 166728 - missing original text in reply to a message
Summary: missing original text in reply to a message
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: composer (show other bugs)
Version: 1.10.0
Platform: unspecified Linux
: HI major with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 166773 166805 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-16 14:55 UTC by sts
Modified: 2008-07-18 17:20 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sts 2008-07-16 14:55:12 UTC
Version:           1.10.0 (using 4.00.98 (KDE 4.0.98 (4.1 RC1)) "release 7.1", KDE:KDE4:Factory:Desktop / openSUSE_11.0)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.25.9-0.2-default

The original message text is missing if I reply a email. The field is empty.
Comment 1 Thomas McGuire 2008-07-16 16:16:56 UTC
I can't reproduce this at all. Do your reply templates have %TEXT in them? What do you mean with "the field"?
Comment 2 sts 2008-07-16 20:45:53 UTC
no, it doesn't have.. only forward have this.. but also with forward it doesn't work.. 

in reply template I have %QUOTE:
%REM=„Standardvorlage für Antworten“%-
Am %ODATEEN %OTIMELONGEN schrieben Sie:
%QUOTE
%CURSOR

with field I mean the text input field.
Comment 3 Thomas McGuire 2008-07-16 21:42:36 UTC
Using Shift+R (Blank Reply) instead?
Comment 4 Thomas McGuire 2008-07-16 22:03:02 UTC
*** Bug 166773 has been marked as a duplicate of this bug. ***
Comment 5 Thomas McGuire 2008-07-16 22:03:52 UTC
Hmmm, seems like more people see this bug.
Maybe this is something opensuse-specific? Haven't seen the bug myself yet.
Comment 6 Eric Sorensen 2008-07-16 22:52:53 UTC
This only appears when forwarding as text. forwarding with the original mail as an attachment functions.  I also don't have %TEXT in my template, but even with it, the forwarding doesn't work.  Just to test things, assuming there was a crash prior to the %TEXT tag, I removed everything and inserted the %TEXT Tag.  That didn't help either.
Comment 7 sts 2008-07-17 09:45:26 UTC
btw: it doesn't work also if I create my own reply template
Comment 8 Thomas McGuire 2008-07-17 12:07:11 UTC
*** Bug 166805 has been marked as a duplicate of this bug. ***
Comment 9 Will Stephenson 2008-07-17 12:08:32 UTC
May be a packaging problem; will check.
Comment 10 Stefan Böhmann 2008-07-17 15:12:47 UTC
Same bug here. My System is a x86 (not a x86_64) and isn't OpenSuse (Gentoo, but KDE build from branches/KDE/4.1/).
Comment 11 Thorsten Staerk 2008-07-17 23:48:44 UTC
Same problem here with x64 OpenSuse. Solution: Scroll upwards.
Comment 12 Allen Winter 2008-07-18 02:13:29 UTC
scroll up?  really?

there was a similar problem a few months back that was solved in qt-copy IIRC.
could you all be linking against qt 4.4.x instead of qt-copy?  Or maybe an older kdelibs?
Comment 13 Thorsten Staerk 2008-07-18 08:42:53 UTC
As I said, I observed this bug several times, but then I saw kmail now adds text at the bottom when replying (why?). Scrolling upwards, I found the original text. This still happens from time to time. This is why I do not confirm this bug - the description "missing original text" is wrong.

Anyone, please confirm the bug really exists and you did not just forget to scroll.
Comment 14 Sebastian Kratzert 2008-07-18 09:37:59 UTC
My KMail definitely does not place any original text in the reply window.
There is no scrollbar.
Comment 15 Sebastian Kratzert 2008-07-18 16:57:00 UTC
I just discovered how to work around the problem. In the identity there has to be anabled the checkbox for "Use custom message tmplate".

Comment 16 Thomas McGuire 2008-07-18 17:15:53 UTC
SVN commit 834288 by tmcguire:

Also allow the german leading quote mark ( Unicode character 0x201C ) as a separator
for template quotes.
This fixes replys and forwards being empty when running under German locale.
Thanks to Friedrich Kröner for figuring out that this bug was locale-dependent (no wonder
we developers couldn't reproduce it).

@Translators:
When translating the templates of KMail, please only use U+0022 or U+201C to translate the 
quotation mark, otherwise you'll trigger this bug. Simply using the ASCII " character is the
best.

CCMAIL: kde-i18n-doc@kde.org
BUG: 166728


 M  +4 -2      templateparser.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=834288
Comment 17 Thomas McGuire 2008-07-18 17:20:48 UTC
SVN commit 834290 by tmcguire:

Backport r834288 by tmcguire to the 4.1 branch:

Also allow the german leading quote mark ( Unicode character 0x201C ) as a separator
for template quotes.
This fixes replys and forwards being empty when running under German locale.
Thanks to Friedrich Kröner for figuring out that this bug was locale-dependent (no wonder
we developers couldn't reproduce it).

CCBUG: 166728


 M  +4 -2      templateparser.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=834290