Bug 166324 - `ShapeInput' was not declared in this scope
Summary: `ShapeInput' was not declared in this scope
Status: RESOLVED NOT A BUG
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-11 21:03 UTC by Mike Perik
Modified: 2012-08-08 19:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Perik 2008-07-11 21:03:14 UTC
Version:            (using KDE 4.0.83)
Installed from:    Compiled From Sources
Compiler:          g++ (GCC) 3.4.6 20060404 (Red Hat 3.4.6-8) 
OS:                Linux

When compiling KDE 4.1 Beta2 from source I get the following error:

[ 17%] Building CXX object apps/dolphin/src/CMakeFiles/dolphinprivate.dir/ktooltip.o
/home/users/mikep/tmp/kde-4.1/kdebase/apps/dolphin/src/ktooltip.cpp: In member function `virtual void ArgbLabel::showTip(const QPoint&, const KToolTipItem*)':
/home/users/mikep/tmp/kde-4.1/kdebase/apps/dolphin/src/ktooltip.cpp:375: error: `ShapeInput' was not declared in this scope
/home/users/mikep/tmp/kde-4.1/kdebase/apps/dolphin/src/ktooltip.cpp:375: warning: unused variable 'ShapeInput'
make[2]: *** [apps/dolphin/src/CMakeFiles/dolphinprivate.dir/ktooltip.o] Error 1
make[1]: *** [apps/dolphin/src/CMakeFiles/dolphinprivate.dir/all] Error 2


I found ShapeInput defined in kdebase/workspace/kwin/utils.h as

// compile with XShape older than 1.0
#ifndef ShapeInput
const int ShapeInput = 2;
#endif

If I add this definition to `kdebase/apps/dolphin/src/ktooltip.cpp
it compiles.

Mike
Comment 1 Christophe Giboudeaux 2008-07-11 22:46:28 UTC
Please don't open bugs about stuff that doesn't compile. Use the appropriate KDE Mailing-List or IRC instead.

Note : you should update your KDE version.
Comment 2 Mike Perik 2008-07-12 02:32:35 UTC
My apologies, I didn't know there was a difference.  Not sure what you mean by 'you should update your KDE version'.  I just did a checkout last night.  I did an update and that did not fix the problem with ShapeInput not being defined.  Isn't 4.0.83 = KDE 4.1 Beta 2?  I would consider the fact that the code doesn't even build a bug.  I have joined the kde-core-devel email list and referenced this report.
Comment 3 Andre Woebbeking 2008-07-13 01:36:45 UTC
KDE 4.1 Beta 2 is more than two weeks old ;-)

Did you checkout tags/KDE/4.0.83/ then you should switch to branches/KDE/4.1/ to get the upcoming RC1 and later 4.1.x.
Comment 4 Mike Perik 2008-07-16 21:11:28 UTC
Ok, I've sent emails to kde-core-devel and asked several times on the #kde irc channel about this problem.  Just trying to help.  

My machine has the 6.8.2 version of X and the 'ShapeInput' definition does not exist in shapes.h.  So, unless you have a newer version of X that has ShapeInput define it will not build.  Should I send a patch in?

Comment 5 Andre Woebbeking 2008-07-19 18:41:11 UTC
Mike, thanks for your report!
Comment 6 Andre Woebbeking 2008-07-19 18:43:22 UTC
I applied the patch to ktooltip.cpp as it's good enough for KWin :-)
Comment 7 Halla Rempt 2012-08-08 19:08:49 UTC
Git commit 14bf061f023b995983491bd7ed22c6a3af338614 by Boudewijn Rempt.
Committed on 08/08/2012 at 21:05.
Pushed by rempt into branch 'calligra/2.5'.

Don't mirror an image with a width of one pixel or less

Since there's nothing to mirror then. This happens when a layer is empty,
for instance because it's just been created.

M  +4    -0    krita/image/kis_transform_worker.cc

http://commits.kde.org/calligra/14bf061f023b995983491bd7ed22c6a3af338614
Comment 8 Halla Rempt 2012-08-08 19:09:01 UTC
Git commit bfade96221b48ca039a464d1628dd461094054b4 by Boudewijn Rempt.
Committed on 08/08/2012 at 21:05.
Pushed by rempt into branch 'master'.

Don't mirror an image with a width of one pixel or less

Since there's nothing to mirror then. This happens when a layer is empty,
for instance because it's just been created.

M  +4    -0    krita/image/kis_transform_worker.cc

http://commits.kde.org/calligra/bfade96221b48ca039a464d1628dd461094054b4