Bug 165502 - ICQ doesn't connect (Client to old)
Summary: ICQ doesn't connect (Client to old)
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: ICQ and AIM Plugins (show other bugs)
Version: 0.12.7
Platform: Gentoo Packages Linux
: NOR major with 194 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 165503 165505 165506 165507 165508 165510 165512 165513 165514 165515 165517 165518 165523 165524 165525 165527 165529 165530 165532 165533 165534 165535 165536 165538 165539 165556 166013 168552 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-01 17:45 UTC by Tilman Klaeger
Modified: 2008-10-23 22:41 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
fix icq login (1.52 KB, patch)
2008-07-01 21:10 UTC, Jan Mette
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tilman Klaeger 2008-07-01 17:45:08 UTC
Version:           0.12.7 (using KDE 3.5.9)
Installed from:    Gentoo Packages
Compiler:          gcc-Version 4.1.2 (Gentoo 4.1.2 p1.0.1) 
OS:                Linux

When trying to connect to the ICQ Server, I get the message with the information, that my client is to old and that I have to fill a bugreport for this. I assume that ICQ changed something on their servers, since there was no problem before, I could connect just a couple hours ago. I did not change anything since then.
Comment 1 Christophe Giboudeaux 2008-07-01 18:11:39 UTC
*** Bug 165503 has been marked as a duplicate of this bug. ***
Comment 2 Christophe Giboudeaux 2008-07-01 18:13:31 UTC
*** Bug 165505 has been marked as a duplicate of this bug. ***
Comment 3 Christophe Giboudeaux 2008-07-01 18:14:29 UTC
*** Bug 165506 has been marked as a duplicate of this bug. ***
Comment 4 Christopher Schwan 2008-07-01 18:17:21 UTC
Same here on my gentoo system and also by friends using kopete - does this problem remain with kde 4 ?
Comment 5 Christophe Giboudeaux 2008-07-01 18:25:08 UTC
*** Bug 165507 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Giboudeaux 2008-07-01 18:25:21 UTC
*** Bug 165508 has been marked as a duplicate of this bug. ***
Comment 7 Henning Mersch 2008-07-01 18:33:34 UTC
*** This bug has been confirmed by popular vote. ***
Comment 8 Christophe Giboudeaux 2008-07-01 18:34:27 UTC
*** Bug 165510 has been marked as a duplicate of this bug. ***
Comment 9 Franz Reinhardt 2008-07-01 18:35:14 UTC
It is working on KDE4
Comment 10 Franz Reinhardt 2008-07-01 18:37:38 UTC
It is working on KDE4
Comment 11 Christophe Giboudeaux 2008-07-01 18:45:37 UTC
*** Bug 165513 has been marked as a duplicate of this bug. ***
Comment 12 Christophe Giboudeaux 2008-07-01 18:45:37 UTC
*** Bug 165512 has been marked as a duplicate of this bug. ***
Comment 13 Christophe Giboudeaux 2008-07-01 18:45:37 UTC
*** Bug 165514 has been marked as a duplicate of this bug. ***
Comment 14 Christophe Giboudeaux 2008-07-01 18:47:26 UTC
*** Bug 165515 has been marked as a duplicate of this bug. ***
Comment 15 Christophe Giboudeaux 2008-07-01 19:12:36 UTC
*** Bug 165517 has been marked as a duplicate of this bug. ***
Comment 16 Christophe Giboudeaux 2008-07-01 19:13:50 UTC
*** Bug 165518 has been marked as a duplicate of this bug. ***
Comment 17 Flo Ostermaier 2008-07-01 19:22:47 UTC
same here (debian + fluxbox), licq and gaim don't connect either. some fixes, yet?
Comment 18 Ralph Müller-Welt 2008-07-01 19:24:12 UTC
Bug confirmed on Kubuntu Hardy 8.04 (Qt: 3.3.8b, KDE: 3.5.9, Kopete: 0.12.7)
Linux 2.6.24-19-generic #1 SMP Wed Jun 18 14:15:37 UTC 2008 x86_64 GNU/Linux

But NOT on Kubunt Hardy 8.04 (Qt: 4.4.0, KDE: 4.00.83 (KDE 4.0.83 (KDE 4.1 Beta2), Kopete: 0.50.80)
Linux 2.6.24-19-generic #1 SMP Wed Jun 18 14:15:37 UTC 2008 x86_64 GNU/Linux
Comment 19 Hans-J. Ullrich 2008-07-01 19:42:38 UTC
Confirmed ! LICQ and some other clients do not work, too. We had had this problem ("bug") some times ago, when ICQ changed suddenly its protocol.

Kind regards

Hans
 
Comment 20 TimoM. 2008-07-01 19:43:52 UTC
Can anybody tell me what to do?? i have the same problem...i use adium on my mac and it shows the same freaking error *_*
Comment 21 heinz 2008-07-01 19:49:18 UTC
same here on opensuse 10.3, kopete 0.12.6 kde 3.5.7 and kopete 0.50.1 kde 4.0.4 (see http://flat32.net/2008/07/01/kopete-does-not-connect-to-the-icq-server)
Comment 22 Daniel Mewes 2008-07-01 19:56:17 UTC
Last time this happened it was enough to just change the version information in kopete/protocols/oscar/liboscar/oscartypes.h (ICQ_MAJOR / ICQ_MINOR) as far as I remember. It could be possible however that more parts of the protocol are changed this time.
Unfortunately I don't have time to look into this today, but sniffing the version bytes in the packages of a the original windows ICQ client may or may not help for this. :-)
Comment 23 Ian Schwarz 2008-07-01 19:57:43 UTC
Yup, openSUSE 11.0 with Kopete 0.12.7 and 0.50.1 fails also.
Comment 24 Juliano F. Ravasi 2008-07-01 19:58:35 UTC
> Can anybody tell me what to do?? i have the same problem...i use adium on my mac
> and it shows the same freaking error *_* 

1. Have patience, you are using a reverse-engineered protocol through an unsupported client, for which the owners (Mirabilis, then AOL) have never shown any good will to support third-party software. This situation is constantly imminent.

2. Switch to the open standard XMPP (Jabber, GoogleTalk) and try to convince your contacts to do the same. I'm using this as an opportunity to convince my last ICQ friends to make the switch.
Comment 25 Matt Rogers 2008-07-01 20:01:49 UTC
*** Bug 165523 has been marked as a duplicate of this bug. ***
Comment 26 Jan Ritzerfeld 2008-07-01 20:03:11 UTC
I can connect again with 0.12.7 after simply adding the default ICQ version from trunk to ~/.kde/share/config/kopeterc:
[ICQVersion]
Build=0x17AB
ClientId=0x010A
ClientString=ICQ Client
Country=us
Lang=en
Major=0x0006
Minor=0x0000
Other=0x00007535
Point=0x0000
Comment 27 Alex "lissyara" Keda 2008-07-01 20:10:03 UTC
it's work!
Thank you very much!
Comment 28 Martin Herkt 2008-07-01 20:10:36 UTC
openSUSE 11.0, Kopete 0.50.80. Works fine.
Comment 29 Pino Toscano 2008-07-01 20:11:06 UTC
*** Bug 165525 has been marked as a duplicate of this bug. ***
Comment 30 Pino Toscano 2008-07-01 20:11:06 UTC
*** Bug 165524 has been marked as a duplicate of this bug. ***
Comment 31 hizel 2008-07-01 20:15:57 UTC
Archlinux 2008.06 Kopete 0.12.7 working :)
Comment 32 Juliano F. Ravasi 2008-07-01 20:17:05 UTC
Comment #26:
> I can connect again with 0.12.7 after simply adding the default ICQ version
> from trunk to ~/.kde/share/config/kopeterc: 

Confirmed fix.
Comment 33 Pino Toscano 2008-07-01 20:24:23 UTC
*** Bug 165527 has been marked as a duplicate of this bug. ***
Comment 34 Rick Stevens 2008-07-01 20:34:59 UTC
Jan's comment 26 confirmed as fixing 0.12.7 on KDE 3.5.9-5 on Fedora 8.
Comment 35 Marcel Juhnke 2008-07-01 20:38:22 UTC
> I can connect again with 0.12.7 after simply adding the default ICQ version
> from trunk to ~/.kde/share/config/kopeterc: 

Also confirmed fix with Kopete 0.50.1 on KDE 4.0.4 on openSUSE 11.0!
Comment 36 Anno V. Heimburg 2008-07-01 20:49:55 UTC
comment 26 confirmed as a fix for kopete-0.12.7/kde-3.5.9 on gentoo
Comment 37 Christophe Giboudeaux 2008-07-01 20:49:56 UTC
*** Bug 165529 has been marked as a duplicate of this bug. ***
Comment 38 Christophe Giboudeaux 2008-07-01 20:50:22 UTC
*** Bug 165530 has been marked as a duplicate of this bug. ***
Comment 39 KonstantinKo 2008-07-01 20:58:49 UTC
Thanks, Working Ok in OpenSUSE 11.0 | kopete 0.12.7
Comment 40 Sven Brauch 2008-07-01 21:10:28 UTC
Don´t get it working with this fix, what to do with the "code"? I just added it to the file you mentioned...
I get another error message, but still one (its just like "failed to login to icq")

what to do? ;)
Comment 41 Jan Mette 2008-07-01 21:10:43 UTC
Created attachment 25779 [details]
fix icq login

This patch fixes the icq login, thanks to g-hennux in #kde for the tip...
Tested and working for me :)

Greetings

Jan
Comment 42 Juliano F. Ravasi 2008-07-01 21:12:32 UTC
We found on IRC that Kopete 0.12.x seems to be trying to automatically update its own ICQ version information the first time it fails to login to ICQ servers, by downloading the file located at: http://kopete.kde.org/oscarversions.xml

Unfortunately, that address is returning HTTP 404 error... it was deleted.

Someone with proper rights to upload to kopete.kde.org could rehost the file, with the right version information, and this problem will automatically be solved for everyone.
Comment 43 Christophe Giboudeaux 2008-07-01 21:14:02 UTC
*** Bug 165533 has been marked as a duplicate of this bug. ***
Comment 44 Pino Toscano 2008-07-01 21:32:54 UTC
*** Bug 165534 has been marked as a duplicate of this bug. ***
Comment 45 Christophe Giboudeaux 2008-07-01 21:35:54 UTC
*** Bug 165536 has been marked as a duplicate of this bug. ***
Comment 46 Pino Toscano 2008-07-01 21:39:31 UTC
*** Bug 165535 has been marked as a duplicate of this bug. ***
Comment 47 Christophe Giboudeaux 2008-07-01 21:50:50 UTC
*** Bug 165538 has been marked as a duplicate of this bug. ***
Comment 48 Matt Rogers 2008-07-01 21:52:37 UTC
Fixed. No software update required.
Comment 49 Henning Mersch 2008-07-01 21:53:21 UTC
> I can connect again with 0.12.7 after simply adding the default ICQ version
> from trunk to ~/.kde/share/config/kopeterc:
[...]
Confirmed fix by Jan/comment #26. 

Thanks!
Comment 50 Lukas 2008-07-01 21:53:22 UTC
I don't want to receive this emails any more if got now 20 times the same email from different persons.
I think you should stop it...
I had looked on the page for Infos
Maybe you can create an uptate for kopete with the new server runtimes...
Gruß Lukas 


-----Ursprüngliche Nachricht-----
Von: owner@bugs.kde.org [mailto:owner@bugs.kde.org] 
Gesendet: Dienstag, 1. Juli 2008 21:41
An: bisdorfl@aol.com
Betreff: [Bug 165502] ICQ doesn't connect (Client to old) 

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
         
http://bugs.kde.org/show_bug.cgi?id=165502         
l.schoenbach gmx de changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|l.schoenbach gmx de         |

pino kde org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mareike_t web de



------- Additional Comments From pino kde org  2008-07-01 21:39 -------
*** Bug 165535 has been marked as a duplicate of this bug. ***
Comment 51 Henning Mersch 2008-07-01 21:54:11 UTC
> I can connect again with 0.12.7 after simply adding the default ICQ version
> from trunk to ~/.kde/share/config/kopeterc:

Confirmed fix by Jam/comment #26. 
Thanks!
Comment 52 Lukas 2008-07-01 21:57:44 UTC
I don't want to receive this emails any more if got now 20 times the same email from different persons.
I think you should stop it...
I had looked on the page for Infos
Maybe you can create an uptate for kopete with the new server runtimes...
Gruß Lukas 


-----Ursprüngliche Nachricht-----
Von: owner@bugs.kde.org [mailto:owner@bugs.kde.org] 
Gesendet: Dienstag, 1. Juli 2008 21:41
An: bisdorfl@aol.com
Betreff: [Bug 165502] ICQ doesn't connect (Client to old) 

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
         
http://bugs.kde.org/show_bug.cgi?id=165502         
l.schoenbach gmx de changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|l.schoenbach gmx de         |

pino kde org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mareike_t web de



------- Additional Comments From pino kde org  2008-07-01 21:39 -------
*** Bug 165535 has been marked as a duplicate of this bug. ***
Comment 53 Pino Toscano 2008-07-01 22:02:36 UTC
@Lukas:
as you prefer.
Comment 54 Lukas 2008-07-01 22:10:30 UTC
Hey wich part of i dont want any more emails from this bug has you not understand????


Gruß Lukas 


-----Ursprüngliche Nachricht-----
Von: owner@bugs.kde.org [mailto:owner@bugs.kde.org] Im Auftrag von Lukas
Gesendet: Dienstag, 1. Juli 2008 21:58
An: bisdorfl@aol.com
Betreff: [Bug 165502] ICQ doesn't connect (Client to old) 

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
         
http://bugs.kde.org/show_bug.cgi?id=165502         




------- Additional Comments From bisdorfl aol com  2008-07-01 21:57 -------
I don't want to receive this emails any more if got now 20 times the same email from different persons.
I think you should stop it...
I had looked on the page for Infos
Maybe you can create an uptate for kopete with the new server runtimes...
Gru Lukas 


-----Ursprngliche Nachricht-----
Von: owner bugs kde org [mailto:owner bugs kde org] 
Gesendet: Dienstag, 1. Juli 2008 21:41
An: bisdorfl aol com
Betreff: [Bug 165502] ICQ doesn't connect (Client to old) 

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
         
http://bugs.kde.org/show_bug.cgi?id=165502         
l.schoenbach gmx de changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|l.schoenbach gmx de         |

pino kde org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mareike_t web de



------- Additional Comments From pino kde org  2008-07-01 21:39 -------
*** Bug 165535 has been marked as a duplicate of this bug. ***
Comment 55 Frank Reininghaus 2008-07-01 22:14:26 UTC
*** Bug 165539 has been marked as a duplicate of this bug. ***
Comment 56 Hans-J. Ullrich 2008-07-01 22:15:27 UTC
Strange, I did NOT update anything, but it is working again !

Maybe they changed something on the server ???

Cheers

Hans
Comment 57 Lukas 2008-07-01 22:18:01 UTC
Ok thank you. 
I had readen messegeboard and now I think I can make it alone..
 


Gruß Lukas 


-----Ursprüngliche Nachricht-----
Von: owner@bugs.kde.org [mailto:owner@bugs.kde.org] Im Auftrag von Pino Toscano
Gesendet: Dienstag, 1. Juli 2008 22:03
An: bisdorfl@aol.com
Betreff: [Bug 165502] ICQ doesn't connect (Client to old) 

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
         
http://bugs.kde.org/show_bug.cgi?id=165502         
pino kde org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|bisdorfl aol com            |



------- Additional Comments From pino kde org  2008-07-01 22:02 -------
 Lukas:
as you prefer.
Comment 58 Lukas 2008-07-01 22:37:38 UTC
Hey wich part of i dont want any more emails from this bug has you not understand????


Gruß Lukas 


-----Ursprüngliche Nachricht-----
Von: owner@bugs.kde.org [mailto:owner@bugs.kde.org] Im Auftrag von Lukas
Gesendet: Dienstag, 1. Juli 2008 21:58
An: bisdorfl@aol.com
Betreff: [Bug 165502] ICQ doesn't connect (Client to old) 

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
         
http://bugs.kde.org/show_bug.cgi?id=165502         




------- Additional Comments From bisdorfl aol com  2008-07-01 21:57 -------
I don't want to receive this emails any more if got now 20 times the same email from different persons.
I think you should stop it...
I had looked on the page for Infos
Maybe you can create an uptate for kopete with the new server runtimes...
Gru Lukas 


-----Ursprngliche Nachricht-----
Von: owner bugs kde org [mailto:owner bugs kde org] 
Gesendet: Dienstag, 1. Juli 2008 21:41
An: bisdorfl aol com
Betreff: [Bug 165502] ICQ doesn't connect (Client to old) 

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
         
http://bugs.kde.org/show_bug.cgi?id=165502         
l.schoenbach gmx de changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|l.schoenbach gmx de         |

pino kde org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mareike_t web de



------- Additional Comments From pino kde org  2008-07-01 21:39 -------
*** Bug 165535 has been marked as a duplicate of this bug. ***
Comment 59 Lukas 2008-07-01 22:39:04 UTC
Ok thank you. 
I had readen messegeboard and now I think I can make it alone..
 


Gruß Lukas 


-----Ursprüngliche Nachricht-----
Von: owner@bugs.kde.org [mailto:owner@bugs.kde.org] Im Auftrag von Pino Toscano
Gesendet: Dienstag, 1. Juli 2008 22:03
An: bisdorfl@aol.com
Betreff: [Bug 165502] ICQ doesn't connect (Client to old) 

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
         
http://bugs.kde.org/show_bug.cgi?id=165502         
pino kde org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|bisdorfl aol com            |



------- Additional Comments From pino kde org  2008-07-01 22:02 -------
 Lukas:
as you prefer.
Comment 60 Matt Rogers 2008-07-01 22:47:26 UTC
Ok, enough with the "it doesn't work here either" messages please. We
know it doesn't work. We need time to work on a fix for the issue.
Please vote for the bug instead of adding "me too" type comments.
Comment 61 Dexter Filmore 2008-07-01 23:55:38 UTC
#26 fixes kopete 0.12.5 in kde 3.5.7 on etch backports as well - thanks.
Comment 62 Pino Toscano 2008-07-02 10:35:56 UTC
*** Bug 165556 has been marked as a duplicate of this bug. ***
Comment 63 stephan 2008-07-02 19:27:02 UTC
kopete 0.12.5 in kde 3.5.9 fixed^^ thx guys
Comment 64 Christophe Giboudeaux 2008-07-08 11:27:44 UTC
*** Bug 166013 has been marked as a duplicate of this bug. ***
Comment 65 Maxim Karavaev 2008-07-08 12:32:34 UTC
Please, somebody help me!!! Where I am wrong? 
I use version 50.1 on SUSE 11 and still can't login to ICQ.
YaST reports:
Version: 4.0.4-19.19
Build Time: Thu 03 Jul 2008 02:07:41 PM SAMST
openSUSE Build Service
Architecture: i586

Is this is a problem of suse repository? Or something else?
Comment 66 Ute Hauth 2008-08-03 18:34:26 UTC
It does not work with the workaround from comment #26 for me
Gentoo 2.6.25-gentoo-r5 kopete 0.12.7 KDE 3.5.9
Comment 67 Alex Minton 2008-08-15 13:25:35 UTC
Same issue on Kopete 0.50.1 with KDE 4.1.0 on openSUSE 11.0
yesterday all was fine, noticed only today...
Comment 68 Roman Jarosz 2008-10-16 00:36:34 UTC
*** Bug 168552 has been marked as a duplicate of this bug. ***
Comment 69 Michael 2008-10-23 22:28:15 UTC
The version update as mentioned above AND changing login server to login.icq.com:443 solved for me on opensuse 11.0 kopete 0.12.7 kde 3.5.9  release 49.1