Bug 165249 - No sound after second video file playback
Summary: No sound after second video file playback
Status: RESOLVED FIXED
Alias: None
Product: dragonplayer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dragon Player Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-28 23:53 UTC by Luciano Leveroni
Modified: 2009-02-05 00:35 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luciano Leveroni 2008-06-28 23:53:45 UTC
Version:            (using Devel)
Installed from:    Compiled sources

If a play a movie everything is fine, after opening another movie from the "Play media" option, the movie is played with no sound. If I close and open Dragon Player again movie plays normally. As simple as that.

I'm using current SVN from trunk (4.0.84) in AMD64 Gentoo, Phonon + Xine. No other sound problems at all.

Thanks.
Comment 1 Paul Thomas 2008-11-24 22:31:34 UTC
I seem to have the same issue. When this happens, does the file you want to play have a name containing non-ascii characters? Does the last file have the same? In my case this is the case and I don't have the issue if I clear the dragonplayer.rc file and only play files with pure ascii names.
Comment 2 Luciano Leveroni 2008-11-25 01:38:41 UTC
@Paul Thomas:

I've done some tests and you are right, I've deleted the dragonplayerrc file and everything is fine, but after opening a video with the char "í" on it, every time you open Dragon Player the first file plays fine but then the next videos that are played have no sound.

Hope this helps to tackled the issue.
Comment 3 David Edmundson 2008-11-25 09:49:31 UTC
That helps a lot. Good work.
Comment 4 Paul B 2009-01-21 20:45:35 UTC
I think the problem here is a Xine problem, it happens when you open a recently opened track (so that it will skip forward to the last position) after watching/listening to any track.

Only tracks in recently viewed list will cause this, and never the first time. Works fine with GStreamer and apparently (David tested it I think) works fine on newer versions of Xine (The one in Kubuntu-proposed is fine according to David)
Comment 5 David Edmundson 2009-01-21 21:27:54 UTC
no, I think the issue is with the setAudioChannel code in the restoring settings from the config file. The indexes don't work quite the way I'd expect them to. There seems to be a unique ID index for the channel, as well as a position in the array of audioChannels, these aren't the same.
Comment 6 David Edmundson 2009-01-21 22:24:36 UTC
SVN commit 914836 by davidedmundson:

BUG:177623
BUG:165249
Check channel validity before setting audio channel.


 M  +7 -5      videoWindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=914836
Comment 7 David Edmundson 2009-02-05 00:35:43 UTC
SVN commit 921398 by davidedmundson:

Backport all the fixes made to Dragonplayer after 4.2.0
Same as trunk revision 918684 except "reset video settings" feature not backported as includes new translation

add a check for unistd.h to the buildsystem.
and include unistd.h in dragonplayer/src/app/videoWindow.cpp, for usleep.
Fixed crash when loading Video after using VideoSettings Dialog, and VideoSettings dialog now only accessible if 
playing a Video file
BUG:177623
BUG:165249
Check channel validity before setting audio channel.
BUG: 171301
Fixes bug 171301 by adding a "Restore defaults" button to video settings dialog and looking for the "valueChanged" 
signal instead of "sliderMoved" for the Vdeo settings slider, ensuring that it will recognise all movements, not 
just those caused by dragging with mouse
When track finished pushing "play" now restarts track
Support for additional MediaSource state 'empty'
BUG:163099 Video window sometimes doesn't resize when opening a file with a restore position.
Supress powermanager from sleeping when playing a file
Replace all references to CODEINE with DRAGONPLAYER
Remove unused code. Fixed compile warning
Implements TheStream::prettyTitle() and removes two unused signals statusMessage(const QString &) and
titleChanged(const QString &) (Now obsolete due to MediaObject::metaDataChanged())
Code tidy up by Paul B
Fix pause button in DragonPart
Enable position slider based on seekableChanged phonon signal
Fix compile
extra ';'
Revert dbus FileChanged signal broken in last commit
Fix compiler warning on inline consts
Remove all of custom Engine::State enum and replace with Phonon::State
General refactor of state changing 



 M  +4 -2      app/actions.cpp  
 M  +2 -2      app/actions.h  
 M  +2 -2      app/adjustSizeButton.h  
 M  +2 -2      app/discSelectionDialog.h  
 M  +3 -5      app/extern.h  
 M  +2 -2      app/fullScreenAction.h  
 M  +2 -2      app/fullScreenToolBarHandler.h  
 M  +2 -2      app/listView.cpp  
 M  +52 -22    app/mainWindow.cpp  
 M  +13 -4     app/mainWindow.h  
 M  +3 -7      app/part.cpp  
 M  +4 -4      app/part.h  
 M  +2 -2      app/partToolBar.h  
 M  +2 -2      app/playDialog.h  
 M  +5 -5      app/playlistFile.cpp  
 M  +2 -2      app/playlistFile.h  
 M  +22 -3     app/recentlyPlayedList.cpp  
 M  +21 -0     app/recentlyPlayedList.h  
 M  +99 -137   app/stateChange.cpp  
 M  +23 -3     app/theStream.cpp  
 M  +5 -4      app/theStream.h  
 M  +40 -72    app/videoWindow.cpp  
 M  +16 -11    app/videoWindow.h  
 M  +33 -47    codeine.h  
 M  +3 -3      dbus/playerDbusHandler.cpp  
 M  +2 -2      dbus/playerDbusHandler.h  
 M  +2 -2      dbus/rootDbusHandler.h  
 M  +3 -3      dbus/trackListDbusHandler.cpp  
 M  +2 -2      dbus/trackListDbusHandler.h  
 M  +10 -17    debug.h  
 M  +3 -3      messageBox.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=921398