Bug 164740 - Juk crash on startup
Summary: Juk crash on startup
Status: RESOLVED WORKSFORME
Alias: None
Product: Phonon
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Matthias Kretz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-23 12:38 UTC by Sean Wilson
Modified: 2008-11-25 14:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
JuK crash backtrace (6.34 KB, text/plain)
2008-06-23 12:47 UTC, Sean Wilson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Wilson 2008-06-23 12:38:51 UTC
Version:           JuK 3.1 (using Devel)
Installed from:    Compiled sources
Compiler:          4.2.3(Ubuntu 4.2.4-2ubuntu7) 
OS:                Linux

JuK crashes on startup, No UI is shown at all.

KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = juk path = <unknown> pid = 27656
sock_file=/home/sean/.kde/socket-intel2duo/kdeinit4__0
juk: Fatal IO error: client killed
juk(27656)/phonon (xine backend): Xine Thread took longer than 10s to quit. Assuming a deadlock. Please report a useful backtrace (including all threads)to bugs.kde.org


Attacted backtrace.
Comment 1 Sean Wilson 2008-06-23 12:47:35 UTC
Created attachment 25537 [details]
JuK crash backtrace

Juk Crash on Startup
Comment 2 Christophe Giboudeaux 2008-06-23 21:45:04 UTC
Application: JuK (juk), signal SIGSEGV
[Thread debugging using libthread_db enabled]
[New Thread 0xb510d9c0 (LWP 27656)]
[New Thread 0xaf41db90 (LWP 27663)]
[New Thread 0xafc60b90 (LWP 27662)]
[New Thread 0xb0461b90 (LWP 27661)]
[New Thread 0xb0c83b90 (LWP 27660)]
[New Thread 0xb154fb90 (LWP 27657)]
[KCrash handler]
#6  xine_post_input (this_gen=0x0, name=0xb38460f9 "parameters")
    at xine_interface.c:870
#7  0xb3837816 in Phonon::Xine::VolumeFaderEffectXT::createInstance (
    this=0x84fedb0)
    at /home/sean/compiled/KDE4.1/kdebase/runtime/phonon/xine/volumefadereffect.cpp:120
#8  0xb38224a6 in Phonon::Xine::EffectXT::ensureInstance (this=0x84fedb0)
    at /home/sean/compiled/KDE4.1/kdebase/runtime/phonon/xine/effect.cpp:74
#9  0xb38225a2 in Phonon::Xine::EffectXT::audioOutputPort (this=0x84fedb0)
    at /home/sean/compiled/KDE4.1/kdebase/runtime/phonon/xine/effect.cpp:49
#10 0xb3825c55 in Phonon::Xine::AudioOutputXT::rewireTo (this=0x83e4a08, 
    source=0x84fedb0)
    at /home/sean/compiled/KDE4.1/kdebase/runtime/phonon/xine/audiooutput.cpp:118
#11 0xb3808fb5 in Phonon::Xine::XineThread::event (this=0x84fbae0, 
    e=0x84ff798)
    at /home/sean/compiled/KDE4.1/kdebase/runtime/phonon/xine/xinethread.cpp:98
#12 0xb5bd6c0c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#13 0xb5bdb7a9 in QApplication::notify () from /usr/lib/libQtGui.so.4
#14 0xb79d64df in KApplication::notify (this=0xbf913028, receiver=0x84fbae0, 
    event=0x84ff798)
    at /home/sean/compiled/KDE4.1/kdelibs/kdeui/kernel/kapplication.cpp:311
#15 0xb7e9c6a9 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#16 0xb7e9da59 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#17 0xb7e9dc7d in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#18 0xb7ec7bcf in ?? () from /usr/lib/libQtCore.so.4
#19 0xb57c7bf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#20 0xb57cae5e in ?? () from /usr/lib/libglib-2.0.so.0
#21 0xb57cb3ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#22 0xb7ec7f98 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#23 0xb7e9b92d in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#24 0xb7e9babd in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#25 0xb7dadf49 in QThread::exec () from /usr/lib/libQtCore.so.4
#26 0xb3808922 in Phonon::Xine::XineThread::run (this=0x84fbae0)
    at /home/sean/compiled/KDE4.1/kdebase/runtime/phonon/xine/xinethread.cpp:111
#27 0xb7db1612 in ?? () from /usr/lib/libQtCore.so.4
#28 0xb7d484fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#29 0xb5925e5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xaf41db90 (LWP 27663)):
#0  0xb7fbf410 in __kernel_vsyscall ()
#1  0xb7d4caa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb37cedb4 in ao_loop (this_gen=0x8623130) at audio_out.c:346
#3  0xb7d484fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#4  0xb5925e5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb510d9c0 (LWP 27656)):
#0  0xb7fbf410 in __kernel_vsyscall ()
#1  0xb7d4cdd2 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb7db2124 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#3  0xb7db122c in QThread::wait () from /usr/lib/libQtCore.so.4
#4  0xb380b723 in ~XineEngine (this=0x842beb0)
    at /home/sean/compiled/KDE4.1/kdebase/runtime/phonon/xine/xineengine.cpp:83
#5  0xb382fe2e in ~Backend (this=0x8420cc0)
    at /home/sean/compiled/KDE4.1/kdebase/runtime/phonon/xine/backend.cpp:94
#6  0xb745a3d5 in Phonon::FactoryPrivate::~FactoryPrivate ()
   from /usr/lib/kde4/lib/libphonon.so.4
#7  0xb7459372 in Phonon::._252::destroy ()
   from /usr/lib/kde4/lib/libphonon.so.4
#8  0xb743c4af in Phonon::CleanUpGlobalStatic::~CleanUpGlobalStatic ()
   from /usr/lib/kde4/lib/libphonon.so.4
#9  0xb74591d0 in __tcf_0 () from /usr/lib/kde4/lib/libphonon.so.4
#10 0xb587d084 in exit () from /lib/tls/i686/cmov/libc.so.6
#11 0xb5c32bfb in ?? () from /usr/lib/libQtGui.so.4
#12 0xb79d5a2e in KApplication::xioErrhandler (this=0xbf913028, dpy=0x8191270)
    at /home/sean/compiled/KDE4.1/kdelibs/kdeui/kernel/kapplication.cpp:418
#13 0xb79d5a6e in kde_xio_errhandler (dpy=0x8191270)
    at /home/sean/compiled/KDE4.1/kdelibs/kdeui/kernel/kapplication.cpp:130
#14 0xb66fd892 in _XIOError () from /usr/lib/libX11.so.6
#15 0xb67042f8 in _XGetXCBBuffer () from /usr/lib/libX11.so.6
#16 0xb67044fd in ?? () from /usr/lib/libX11.so.6
#17 0xb6705200 in _XReply () from /usr/lib/libX11.so.6
#18 0xb66e2e2c in XGetImage () from /usr/lib/libX11.so.6
#19 0xb5ca0fff in ?? () from /usr/lib/libQtGui.so.4
#20 0xb5c94c24 in QPixmap::toImage () from /usr/lib/libQtGui.so.4
#21 0xb79ac35f in KPixmapCache::Private::writeData (this=0x81b25e8, 
    key=@0xbf912d88, pix=@0xbf912cf8)
    at /home/sean/compiled/KDE4.1/kdelibs/kdeui/icons/kpixmapcache.cpp:1425
#22 0xb79ace87 in KPixmapCache::insert (this=0x8210788, key=@0xbf912d88, 
    pix=@0xbf912cf8)
    at /home/sean/compiled/KDE4.1/kdelibs/kdeui/icons/kpixmapcache.cpp:1391
#23 0xb79a5f09 in KIconCache::insert (this=0x8210788, key=@0xbf912d88, 
    pix=@0xbf912cf8)
    at /home/sean/compiled/KDE4.1/kdelibs/kdeui/icons/kiconcache.cpp:298
#24 0xb79a5eaa in KIconCache::insert (this=0x8210788, key=@0xbf912d88, 
    pix=@0xbf912cf8, path=@0xbf912dc8)
    at /home/sean/compiled/KDE4.1/kdelibs/kdeui/icons/kiconcache.cpp:285
#25 0xb799b26e in KIconLoader::loadIcon (this=0x81af330, _name=@0xbf912f30, 
    group=KIconLoader::Panel, size=22, state=0, overlays=@0xbf912e30, 
    path_store=0x0, canReturnNull=false)
    at /home/sean/compiled/KDE4.1/kdelibs/kdeui/icons/kiconloader.cpp:1227
#26 0xb7a4ed1f in KSystemTrayIcon::loadIcon (icon=@0xbf912f30, 
    componentData=@0x8180bc0)
    at /home/sean/compiled/KDE4.1/kdelibs/kdeui/util/ksystemtrayicon.cpp:340
#27 0x08103a19 in SystemTray (this=0x83e41a8, parent=0x81e8d38)
    at /home/sean/compiled/KDE4.1/kdemultimedia/juk/systemtray.cpp:186
#28 0x080b680c in JuK::setupSystemTray (this=0x81e8d38)
    at /home/sean/compiled/KDE4.1/kdemultimedia/juk/juk.cpp:288
#29 0x080ba4f0 in JuK (this=0x81e8d38, parent=0x0)
    at /home/sean/compiled/KDE4.1/kdemultimedia/juk/juk.cpp:93
#30 0x080be8e9 in main (argc=1, argv=0xbf913244)
    at /home/sean/compiled/KDE4.1/kdemultimedia/juk/main.cpp:89
#0  0xb7fbf410 in __kernel_vsyscall ()
Comment 3 Scott Wheeler 2008-06-30 01:36:34 UTC
Crash is in Phonon-Xine's volume plugin.
Comment 4 Lubos Lunak 2008-07-21 16:23:12 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 5 Matthias Kretz 2008-11-25 14:45:34 UTC
Closing since the backtrace doesn't show where the real problem is (XIO Error caused shutdown). If you can still reproduce please reopen.