Bug 164569 - Statusbar does not display status of accounts
Summary: Statusbar does not display status of accounts
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 164641 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-20 23:41 UTC by Jan Binder
Modified: 2008-07-09 20:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Show last identity widget (2.50 KB, patch)
2008-06-21 10:17 UTC, Roman Jarosz
Details
Show account icons in status bar (13.77 KB, patch)
2008-06-21 17:36 UTC, Roman Jarosz
Details
Show account icons in status bar (+animation) (14.46 KB, patch)
2008-06-22 13:01 UTC, Roman Jarosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Binder 2008-06-20 23:41:30 UTC
Version:            (using KDE 4.0.80)
Installed from:    Debian testing/unstable Packages
OS:                Linux

The new statusbar in Kopete does not reflect the status of the different accounts in a compact way and does not provide the comfort of the old design, where an account failing to login could easily be handled seperately. Using the "slide-up" menu is slightly more complicated and even there, the account status is not reflected in any way.
Adding an option to restore this part of the old behaviour would be more comfortable.
Comment 1 Dennis Nienhüser 2008-06-21 00:10:00 UTC
The status widget icon uses the identity icon with an overlay for the connection status (indicating the "highest" status). I'd call that a compact representation. If you want more details, you can open the status widget and the account icons indicate the status. From your description it sounds like the icons are not updated for you?

For the sliding being more complicated I think remembering its state upon exiting kopete would improve that? Or are you looking at saving the space occupied by the status widget?
Comment 2 Roman Jarosz 2008-06-21 10:17:47 UTC
Created attachment 25494 [details]
Show last identity widget

I've already have a patch that remembers which identity widget was shown on
exit and it shows it again at startup. Don't know if I can commit it because we
are in feature freeze.
Comment 3 Dennis Nienhüser 2008-06-21 11:00:21 UTC
The patch looks good from reading over it, one question: What does
-		activateWindow();
+		KWindowSystem::activateWindow ( winId() );
change?
Comment 4 Roman Jarosz 2008-06-21 11:08:55 UTC
It shouldn't be in this patch. I was testing hide/show of contact list window because sometimes the window isn't raised.
Comment 5 Jan Binder 2008-06-21 13:50:55 UTC
I'm looking at saving space and getting information at the same time. 

My problem is that some of the accounts I have fail to login occasionally or take a very long time and it is quite complicated to see what is going on.

The status widget does update, but it does not show which account is still trying to connect, they are displayed as "online". 

Especially for Jabber accounts it is hard to see wheteher they are online or offline, a slight background tint might help there (redish or greenish etc).

Remembering the state of the widget would be a good idea anyway.

I also noticed that the main toolbar does not remember state and position, but I should probably file a different bug for that.
Comment 6 Roman Jarosz 2008-06-21 17:36:36 UTC
Created attachment 25503 [details]
Show account icons in status bar

This patch allows showing accounts in status bar instead of identities. If
nobody objects I'll commit it when feature freeze is lifted.
The check box is in Contact List on Contact List tab. (will try to find better
place for it).

This patch also contains the show last identity widget patch.
Comment 7 Jan Binder 2008-06-22 01:40:25 UTC
Cannot test right now because the CVS version does not compile for me at
the moment.

Will close on commit, thanks for the quick reaction :-).
Comment 8 Dennis Nienhüser 2008-06-22 10:14:18 UTC
*** Bug 164641 has been marked as a duplicate of this bug. ***
Comment 9 Roman Jarosz 2008-06-22 13:01:42 UTC
Created attachment 25514 [details]
Show account icons in status bar (+animation)

Ok, here's probably last update that adds status animation. We will need new
mng files because now we have the old one and it doesn't look good.

Jan: this wish will be closed automatically when I commit it.
Comment 10 Matt Rogers 2008-06-23 02:37:18 UTC
The patch that fixes this bug can be committed. I don't consider it a new 
feature.
Comment 11 Roman Jarosz 2008-07-09 20:01:20 UTC
SVN commit 830078 by rjarosz:

Allow Kopete to show accounts in status bar of contact list as it was in KDE 3.5.
Remember last opened identity status widget and show it on startup.

We need new animated icons for all protocols.

BUG: 164569
GUI:



 M  +6 -5      kopete/CMakeLists.txt  
 M  +95 -70    kopete/config/appearance/appearanceconfig_contactlist.ui  
 A             kopete/kopeteaccountstatusbaricon.cpp   [License: GPL (v2+)]
 A             kopete/kopeteaccountstatusbaricon.h   [License: GPL (v2+)]
 M  +4 -3      kopete/kopeteapplication.cpp  
 M  +104 -13   kopete/kopetewindow.cpp  
 M  +5 -0      libkopete/kopeteappearancesettings.kcfg  


WebSVN link: http://websvn.kde.org/?view=rev&revision=830078