Bug 163662 - Optional smooth scaling of pictures
Summary: Optional smooth scaling of pictures
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-frame (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 165230 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-09 23:35 UTC by Dennis Nienhüser
Modified: 2008-07-10 19:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
plasma-frame-smooth-scaling-option.diff (4.62 KB, patch)
2008-06-09 23:41 UTC, Dennis Nienhüser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Nienhüser 2008-06-09 23:35:55 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Right now a linear transformation is used to scale pictures which usually gives bad results. Qt allows smooth scaling, but this transformation is noticably more cpu intensive and therefore not always possible. The patch attached adds an option to use smooth scaling (can't check in directly due to message freeze).
Comment 1 Dennis Nienhüser 2008-06-09 23:41:13 UTC
Created attachment 25229 [details]
plasma-frame-smooth-scaling-option.diff
Comment 2 Dennis Nienhüser 2008-06-26 21:13:02 UTC
SVN commit 824870 by nienhueser:

Use smooth scaling to resize the image, which looks better most times.
CCBUG: 163662


 M  +1 -1      frame.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=824870
Comment 3 Anne-Marie Mahfouf 2008-06-28 23:15:35 UTC
*** Bug 165230 has been marked as a duplicate of this bug. ***
Comment 4 Dennis Nienhüser 2008-07-10 19:29:13 UTC
SVN commit 830516 by nienhueser:

Allow switching scaling algorithm.
BUG: 163662


 M  +11 -1     config.ui  
 M  +10 -0     configdialog.cpp  
 M  +3 -0      configdialog.h  
 M  +6 -1      frame.cpp  
 M  +2 -0      frame.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=830516