Bug 163643 - kwin cpu usage increases to 80-90% with compositing on
Summary: kwin cpu usage increases to 80-90% with compositing on
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 164398 165156 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-09 18:55 UTC by Bharat Rajagopalan
Modified: 2009-01-27 11:34 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bharat Rajagopalan 2008-06-09 18:55:43 UTC
Version:           from kde 4.1 beta 1 (using Devel)
Installed from:    Compiled sources
OS:                Linux

I am using kubuntu 64 bit with the realtime kernel (2.6.18-rt)

I have a intel quad core with 4 GB ram and an nvidia geforce 8800 GT

I have installed the kde 4.1 beta 1 kubuntu packages.

I use ardour2 and jackd for recording music

when i play back around 16 tracks in ardour with various lapdsa plugins (C* compressor,eq, TAPS reverb, lame butterworth high pass filter on each track), kwin usage shoots up to around 80-90% when compositing is enabled and the ui responsiveness slows down (fps appears to go down, because i can see the frames skipping when the audio meter display changes). Audio still continues to playback perfectly due to the realtime priority that is set.


This problem doesn't happen

1) in kde 3.5.9 with compiz fusion enabled. system is very responsive
2) in kde 4.1 beta 1 if i am playing or recording only a few tracks (2 or 3)
3) in kde 4.1 beta 1 without compositing enabled

I am not sure what the connection is between ardour tracks and kwin's cpu usage, but there does appear to be a correlation. I wonder if it is due to the mixer, in the sense , the only ui change i can think of is the volume meter changes per track/channel.

Please note that when compositing is not enabled, each of the four processor usage hardly shoots above 15%-20% (viewed using htop). However when compositing enabled the processor usage shoots to nearly 65% on each core (All 4). Kwin is then shown using the highest cpu at around 80%.

With effects enabled these are my settings:
OpenGL
Texture from pixmap
Trilnear (best)

Disabled: VSync (enabling this makes the animations less smooth)
Disabled: keep hidden windows up to date (enabling this option appears to slow things down further)

Changing from Trilinear to Nearest (Fastest) improves it a little, but the system still crawls.

Please let me know if you require any other information. Thanks for your time.

Thanks and regards,
Bharat Rajagopalan
Comment 1 Lubos Lunak 2008-06-10 16:40:32 UTC
Can you please attach gdb to kwin when the problem occurs (not from the same X session, or it will freeze) and provide some backtraces? http://techbase.kde.org/Development/Tutorials/Debugging should have some howtos.
Comment 2 Bharat Rajagopalan 2008-06-12 17:41:54 UTC
hi, 

heres the trace:

mendred@dantooine:~$ killall kwin; gdb kwin                                   
GNU gdb 6.8-debian                                                            
Copyright (C) 2008 Free Software Foundation, Inc.                             
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> 
This is free software: you are free to change and redistribute it.            
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"    
and "show warranty" for details.                                              
This GDB was configured as "x86_64-linux-gnu"...                              
(gdb) set args --nograb --sync --nocrashhandler                               
(gdb) run                                                                     
Starting program: /usr/lib/kde4/bin/kwin --nograb --sync --nocrashhandler     
[Thread debugging using libthread_db enabled]                                 
[New Thread 0x7f6e09c4c7e0 (LWP 7733)]                                        
X Error: BadWindow (invalid Window parameter) 3                               
  Major opcode: 20 (X_GetProperty)                                            
  Resource id:  0x1600027                                                     
kwin(7733) KWin::Application::Application: Running KWin in sync mode          
kwin(7733) KDecorationPlugins::loadPlugin: kwin : path  "/usr/lib/kde4/lib/kde4/kwin3_oxygen.so"  for  "kwin3_oxygen"                                           

Program received signal SIGINT, Interrupt.
[Switching to Thread 0x7f6e09c4c7e0 (LWP 7733)]
0x00007f6e0fc9a320 in ?? () from /usr/lib/libQtGui.so.4
(gdb) bt                                               
#0  0x00007f6e0fc9a320 in ?? () from /usr/lib/libQtGui.so.4
#1  0x00007f6e0fcf56f5 in ?? () from /usr/lib/libQtGui.so.4
#2  0x00007f6e0fcf7939 in ?? () from /usr/lib/libQtGui.so.4
#3  0x00007f6e0fcf7ce5 in ?? () from /usr/lib/libQtGui.so.4
#4  0x00007f6e0fcf9f29 in QRegion::operator+= () from /usr/lib/libQtGui.so.4
#5  0x00007f6e11ebcfc3 in KWin::Toplevel::addDamage (this=0xddd810, x=543,
    y=296, w=2, h=3)
    at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:531
#6  0x00007f6e11ebd12e in KWin::Toplevel::damageNotifyEvent (this=0xddd810,
    e=<value optimized out>)
    at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:498
#7  0x00007f6e11ebd179 in KWin::Client::damageNotifyEvent (this=0xc51ac8,
    e=0x400) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:507
#8  0x00007f6e11e910c1 in KWin::Client::windowEvent (this=0xddd810,
    e=0x7fff1a31ed60)
    at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:720
#9  0x00007f6e11e913d7 in KWin::Workspace::workspaceEvent (this=0x74a110,
    e=0x7fff1a31ed60)
    at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:296
#10 0x00007f6e11e83fe9 in KWin::Application::x11EventFilter (
    this=0x7fff1a31f140, e=0x7fff1a31ed60)
    at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:359
#11 0x00007f6e0fbc137f in ?? () from /usr/lib/libQtGui.so.4
#12 0x00007f6e0fbceb89 in QApplication::x11ProcessEvent ()
   from /usr/lib/libQtGui.so.4
#13 0x00007f6e0fbf58f3 in ?? () from /usr/lib/libQtGui.so.4
#14 0x00007f6e0d483262 in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#15 0x00007f6e0d486516 in ?? () from /usr/lib/libglib-2.0.so.0
#16 0x00007f6e0d4869af in g_main_context_iteration ()
   from /usr/lib/libglib-2.0.so.0
#17 0x00007f6e10fae3af in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#18 0x00007f6e0fbf572f in ?? () from /usr/lib/libQtGui.so.4
#19 0x00007f6e10f84585 in QEventLoop::processEvents ()
   from /usr/lib/libQtCore.so.4
#20 0x00007f6e10f846db in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#21 0x00007f6e10f86729 in QCoreApplication::exec ()
   from /usr/lib/libQtCore.so.4
---Type <return> to continue, or q <return> to quit---Killed

Thanks and regards,
Bharat Rajagopalan
Comment 3 Lubos Lunak 2008-06-13 11:37:49 UTC
Is the backtrace the same if you do it repeatedly (i.e. continue and Ctrl+C again later)? This one suggests it is caused by some application repainting itself.
Comment 4 Bharat Rajagopalan 2008-06-14 08:33:05 UTC
hi lubos,

PFI the trace with initial run and after continue (ardour was running throughout..).

ardour is continuously repainting itself in the sense..it has volume level meters that keep changing as the track plays..it also has big clock that keeps incrementing the time position of the track as it plays..

when the system slows down, it is obvious that kwin's frames per second is dropping while all processes are actually running normally (Ardour plays the tracks back without skipping), so it does seem to be  a repainting problem

Thanks
Bharat

mendred@dantooine:~$ gdb kwin                          
GNU gdb 6.8-debian                                     
Copyright (C) 2008 Free Software Foundation, Inc.      
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.           
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"   
and "show warranty" for details.                                             
This GDB was configured as "x86_64-linux-gnu"...                             
(gdb) set args --nograb --sync --nocrashhandler  --replace
(gdb) run                                                 
Starting program: /usr/lib/kde4/bin/kwin --nograb --sync --nocrashhandler  --replace
[Thread debugging using libthread_db enabled]                                       
[New Thread 0x7f121470e7e0 (LWP 8246)]                                              
X Error: BadWindow (invalid Window parameter) 3                                     
  Major opcode: 20 (X_GetProperty)                                                  
  Resource id:  0x3c00028                                                           
kwin(8246) KWin::Application::Application: Running KWin in sync mode                
kwin(8246) KDecorationPlugins::loadPlugin: kwin : path  "/usr/lib/kde4/lib/kde4/kwin3_oxygen.so"  for  "kwin3_oxygen"

Program received signal SIGINT, Interrupt.
[Switching to Thread 0x7f121470e7e0 (LWP 8246)]
0x00007f121a7b77f3 in ?? () from /usr/lib/libQtGui.so.4
(gdb) bt                                               
#0  0x00007f121a7b77f3 in ?? () from /usr/lib/libQtGui.so.4
#1  0x00007f121a7b99f1 in ?? () from /usr/lib/libQtGui.so.4
#2  0x00007f121a7b9ce5 in ?? () from /usr/lib/libQtGui.so.4
#3  0x00007f121a7bbf29 in QRegion::operator+= () from /usr/lib/libQtGui.so.4
#4  0x00007f121c97efc3 in KWin::Toplevel::addDamage (this=0xdc8b50, x=679, y=291, w=2, h=20) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:531
#5  0x00007f121c97f12e in KWin::Toplevel::damageNotifyEvent (this=0xdc8b50, e=<value optimized out>) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:498
#6  0x00007f121c97f179 in KWin::Client::damageNotifyEvent (this=0x28d, e=0x2b4) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:507                     
#7  0x00007f121c9530c1 in KWin::Client::windowEvent (this=0xdc8b50, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:720                  
#8  0x00007f121c9533d7 in KWin::Workspace::workspaceEvent (this=0x73a3f0, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:296            
#9  0x00007f121c945fe9 in KWin::Application::x11EventFilter (this=0x7fff24de1570, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:359      
#10 0x00007f121a68337f in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#11 0x00007f121a690b89 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4                                                                               
#12 0x00007f121a6b78f3 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#13 0x00007f1217f45262 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0                                                                                  
#14 0x00007f1217f48516 in ?? () from /usr/lib/libglib-2.0.so.0                                                                                                       
#15 0x00007f1217f489af in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0                                                                                 
#16 0x00007f121ba703af in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4                                                                        
#17 0x00007f121a6b772f in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#18 0x00007f121ba46585 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4                                                                                  
#19 0x00007f121ba466db in QEventLoop::exec () from /usr/lib/libQtCore.so.4                                                                                           
#20 0x00007f121ba48729 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4                                                                                     
#21 0x00007f121c94717d in kdemain (argc=5, argv=0x7fff24de1a28) at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:510                                          
#22 0x00007f121c5c41c4 in __libc_start_main () from /lib/libc.so.6                                                                                                   
#23 0x0000000000400649 in _start ()                                                                                                                                  
(gdb)                                                                                                                                                                
#0  0x00007f121a7b77f3 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#1  0x00007f121a7b99f1 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#2  0x00007f121a7b9ce5 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#3  0x00007f121a7bbf29 in QRegion::operator+= () from /usr/lib/libQtGui.so.4                                                                                         
#4  0x00007f121c97efc3 in KWin::Toplevel::addDamage (this=0xdc8b50, x=679, y=291, w=2, h=20) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:531        
#5  0x00007f121c97f12e in KWin::Toplevel::damageNotifyEvent (this=0xdc8b50, e=<value optimized out>) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:498
#6  0x00007f121c97f179 in KWin::Client::damageNotifyEvent (this=0x28d, e=0x2b4) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:507                     
#7  0x00007f121c9530c1 in KWin::Client::windowEvent (this=0xdc8b50, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:720                  
#8  0x00007f121c9533d7 in KWin::Workspace::workspaceEvent (this=0x73a3f0, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:296            
#9  0x00007f121c945fe9 in KWin::Application::x11EventFilter (this=0x7fff24de1570, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:359      
#10 0x00007f121a68337f in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#11 0x00007f121a690b89 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4                                                                               
#12 0x00007f121a6b78f3 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#13 0x00007f1217f45262 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0                                                                                  
#14 0x00007f1217f48516 in ?? () from /usr/lib/libglib-2.0.so.0                                                                                                       
#15 0x00007f1217f489af in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0                                                                                 
#16 0x00007f121ba703af in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4                                                                        
#17 0x00007f121a6b772f in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#18 0x00007f121ba46585 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4                                                                                  
#19 0x00007f121ba466db in QEventLoop::exec () from /usr/lib/libQtCore.so.4                                                                                           
#20 0x00007f121ba48729 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4                                                                                     
#21 0x00007f121c94717d in kdemain (argc=5, argv=0x7fff24de1a28) at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:510                                          
#22 0x00007f121c5c41c4 in __libc_start_main () from /lib/libc.so.6                                                                                                   
#23 0x0000000000400649 in _start ()                                                                                                                                  
(gdb)                                                                                                                                                                
#0  0x00007f121a7b77f3 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#1  0x00007f121a7b99f1 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#2  0x00007f121a7b9ce5 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#3  0x00007f121a7bbf29 in QRegion::operator+= () from /usr/lib/libQtGui.so.4                                                                                         
#4  0x00007f121c97efc3 in KWin::Toplevel::addDamage (this=0xdc8b50, x=679, y=291, w=2, h=20) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:531        
#5  0x00007f121c97f12e in KWin::Toplevel::damageNotifyEvent (this=0xdc8b50, e=<value optimized out>) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:498
#6  0x00007f121c97f179 in KWin::Client::damageNotifyEvent (this=0x28d, e=0x2b4) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:507                     
#7  0x00007f121c9530c1 in KWin::Client::windowEvent (this=0xdc8b50, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:720                  
#8  0x00007f121c9533d7 in KWin::Workspace::workspaceEvent (this=0x73a3f0, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:296            
#9  0x00007f121c945fe9 in KWin::Application::x11EventFilter (this=0x7fff24de1570, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:359      
#10 0x00007f121a68337f in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#11 0x00007f121a690b89 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4                                                                               
#12 0x00007f121a6b78f3 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#13 0x00007f1217f45262 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0                                                                                  
#14 0x00007f1217f48516 in ?? () from /usr/lib/libglib-2.0.so.0                                                                                                       
#15 0x00007f1217f489af in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0                                                                                 
#16 0x00007f121ba703af in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4                                                                        
#17 0x00007f121a6b772f in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#18 0x00007f121ba46585 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4                                                                                  
#19 0x00007f121ba466db in QEventLoop::exec () from /usr/lib/libQtCore.so.4                                                                                           
#20 0x00007f121ba48729 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4                                                                                     
#21 0x00007f121c94717d in kdemain (argc=5, argv=0x7fff24de1a28) at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:510                                          
#22 0x00007f121c5c41c4 in __libc_start_main () from /lib/libc.so.6                                                                                                   
#23 0x0000000000400649 in _start ()                                                                                                                                  
(gdb)                                                                                                                                                                
#0  0x00007f121a7b77f3 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#1  0x00007f121a7b99f1 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#2  0x00007f121a7b9ce5 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#3  0x00007f121a7bbf29 in QRegion::operator+= () from /usr/lib/libQtGui.so.4                                                                                         
#4  0x00007f121c97efc3 in KWin::Toplevel::addDamage (this=0xdc8b50, x=679, y=291, w=2, h=20) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:531        
#5  0x00007f121c97f12e in KWin::Toplevel::damageNotifyEvent (this=0xdc8b50, e=<value optimized out>) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:498
#6  0x00007f121c97f179 in KWin::Client::damageNotifyEvent (this=0x28d, e=0x2b4) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:507                     
#7  0x00007f121c9530c1 in KWin::Client::windowEvent (this=0xdc8b50, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:720                  
#8  0x00007f121c9533d7 in KWin::Workspace::workspaceEvent (this=0x73a3f0, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:296            
#9  0x00007f121c945fe9 in KWin::Application::x11EventFilter (this=0x7fff24de1570, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:359      
#10 0x00007f121a68337f in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#11 0x00007f121a690b89 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4                                                                               
#12 0x00007f121a6b78f3 in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#13 0x00007f1217f45262 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0                                                                                  
#14 0x00007f1217f48516 in ?? () from /usr/lib/libglib-2.0.so.0                                                                                                       
#15 0x00007f1217f489af in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0                                                                                 
#16 0x00007f121ba703af in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4                                                                        
#17 0x00007f121a6b772f in ?? () from /usr/lib/libQtGui.so.4                                                                                                          
#18 0x00007f121ba46585 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4                                                                                  
#19 0x00007f121ba466db in QEventLoop::exec () from /usr/lib/libQtCore.so.4                                                                                           
#20 0x00007f121ba48729 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4                                                                                     
#21 0x00007f121c94717d in kdemain (argc=5, argv=0x7fff24de1a28) at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:510                                          
#22 0x00007f121c5c41c4 in __libc_start_main () from /lib/libc.so.6                                                                                                   
#23 0x0000000000400649 in _start ()                                                                                                                                  
(gdb) continue                                                                                                                                                       
Continuing.

Program received signal SIGINT, Interrupt.
0x00007f121a7b96ab in ?? () from /usr/lib/libQtGui.so.4
(gdb)
Continuing.


Program received signal SIGINT, Interrupt.
0x00007f121c622e4b in memcpy () from /lib/libc.so.6
(gdb)
Continuing.
bt

Program received signal SIGINT, Interrupt.
0x00007f121c622f99 in memcpy () from /lib/libc.so.6
(gdb) bt
#0  0x00007f121c622f99 in memcpy () from /lib/libc.so.6
#1  0x00007f121b9b15d9 in QVectorData::malloc () from /usr/lib/libQtCore.so.4
#2  0x00007f121a75c2dd in ?? () from /usr/lib/libQtGui.so.4
#3  0x00007f121a7b9567 in ?? () from /usr/lib/libQtGui.so.4
#4  0x00007f121a7b9ce5 in ?? () from /usr/lib/libQtGui.so.4
#5  0x00007f121a7bbf29 in QRegion::operator+= () from /usr/lib/libQtGui.so.4
#6  0x00007f121c97efb7 in KWin::Toplevel::addDamage (this=0xdc8b50, x=815, y=317, w=1, h=4) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:530
#7  0x00007f121c97f12e in KWin::Toplevel::damageNotifyEvent (this=0xdc8b50, e=<value optimized out>) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:498
#8  0x00007f121c97f179 in KWin::Client::damageNotifyEvent (this=0x670e020, e=0x671e030) at /build/buildd/kdebase-workspace-4.0.80/kwin/composite.cpp:507
#9  0x00007f121c9530c1 in KWin::Client::windowEvent (this=0xdc8b50, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:720
#10 0x00007f121c9533d7 in KWin::Workspace::workspaceEvent (this=0x73a3f0, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/events.cpp:296
#11 0x00007f121c945fe9 in KWin::Application::x11EventFilter (this=0x7fff24de1570, e=0x7fff24de1190) at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:359
#12 0x00007f121a68337f in ?? () from /usr/lib/libQtGui.so.4
#13 0x00007f121a690b89 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#14 0x00007f121a6b78f3 in ?? () from /usr/lib/libQtGui.so.4
#15 0x00007f1217f45262 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#16 0x00007f1217f48516 in ?? () from /usr/lib/libglib-2.0.so.0
#17 0x00007f1217f489af in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#18 0x00007f121ba703af in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#19 0x00007f121a6b772f in ?? () from /usr/lib/libQtGui.so.4
#20 0x00007f121ba46585 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#21 0x00007f121ba466db in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#22 0x00007f121ba48729 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#23 0x00007f121c94717d in kdemain (argc=5, argv=0x7fff24de1a28) at /build/buildd/kdebase-workspace-4.0.80/kwin/main.cpp:510
#24 0x00007f121c5c41c4 in __libc_start_main () from /lib/libc.so.6
#25 0x0000000000400649 in _start ()
(gdb) Killed
Comment 5 Lubos Lunak 2008-06-20 17:53:23 UTC
That still suggests it is the application repainting repeatedly. Please enable the 'Show Paint' effect and use it to check for such repaints.
Comment 6 Bharat Rajagopalan 2008-06-29 06:21:20 UTC
Hi,

Enabling the show paint, basically shows that the entire application (ardour and jamin) are repainting themself repeatedly. This happens because,

Ardour
*The volume meters for different tracks are repainting to represent the current volume
*There is a position indicator that moves horizontally across all tracks when it is being played 


jamin:
*This shows the EQ spectrum of the audio being played as well as the current volume levels across freq bands. So when the track is being played the display updates itself.

In any case, right now I have got around this issue for the time being by using compiz-fusion with kde4. 

I guess this would be a very low priority bug since it probably occurs only with cpu intensive apps (like ardour/jack/jamin) with kde4 compositing and most ppl would not be using those apps. So you can close it for the time being as i guess kde 4.1 release is around the corner and you would want to focus on that. I think as kde4 compositing improves in performance terms this bug would also go away.

Thanks for your time
Bharat 
Comment 7 Lubos Lunak 2008-07-22 20:08:25 UTC
*** Bug 164398 has been marked as a duplicate of this bug. ***
Comment 8 Lubos Lunak 2008-07-22 20:21:10 UTC
SVN commit 836664 by lunakl:

Try to handle gracefully the case when there are many small changes
on the screen and the X server has absolutely no problem with flooding
KWin with a huge number of damage events, overloading both the X connection
and QRegion.
BUG: 163643



 M  +28 -2     composite.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=836664
Comment 9 Lubos Lunak 2008-07-24 16:10:42 UTC
*** Bug 165156 has been marked as a duplicate of this bug. ***
Comment 10 Bharat Rajagopalan 2008-08-07 17:04:54 UTC
Hi Lubos,

I can confirm that this issue is fixed (latest kde 4.1 from kubuntu repositories. In fact the compositing system on the whole is snappier especially when using the present windows and desktop grid. 

Now i can record in peace without my UI slowing down :).Thank you for resolving this.

Regards,
Bharat
Comment 11 Christophe Giboudeaux 2009-01-27 11:34:13 UTC
*** Bug 165156 has been marked as a duplicate of this bug. ***