Bug 163630 - Wish: allow icon hiding in system tray
Summary: Wish: allow icon hiding in system tray
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-systemtray (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 25 votes (vote)
Target Milestone: ---
Assignee: Sebastian Sauer
URL:
Keywords:
: 164566 165215 169441 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-09 17:03 UTC by monstermunch
Modified: 2008-08-19 16:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description monstermunch 2008-06-09 17:03:56 UTC
Version:            (using Devel)
Installed from:    Compiled sources

I find the icon hiding feature of KDE3's system tray very useful as I have lots of tray icons that I rarely use or need to see. It would be great to have this feature again in KDE4. Thanks.
Comment 1 Pino Toscano 2008-06-21 02:13:29 UTC
*** Bug 164566 has been marked as a duplicate of this bug. ***
Comment 2 Pino Toscano 2008-06-28 17:27:04 UTC
*** Bug 165215 has been marked as a duplicate of this bug. ***
Comment 3 ariellov 2008-07-01 01:33:48 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Iuri Fiedoruk 2008-07-08 19:14:53 UTC
Please consider adding this feature as soon as possible.
A good reason for it, is using plasma on small devices like openMoko, eeePC and such.
If there is a way to do this with a script language instead of C++ I'm willing to help out. 
I know C++, but I do not have the time to compile whole plasma to testing :-(
Comment 5 Sebastian Sauer 2008-07-09 05:30:40 UTC
Nearly done. I just wait for trunk to open for features again + once done a review/ok from the other plasma-developers :)
Comment 6 Sebastian Sauer 2008-07-21 16:08:22 UTC
the initial work got committed with r835980 into playground/base/plasma/applets/systray-refactor which is planned to replace the systray in 4.2. So, it will be available in 4.2 :)
Comment 7 Iuri Fiedoruk 2008-07-21 17:49:59 UTC
Sorry for the SPAM, but I had to say: thank you very much.
4.2 will surely surpass 3.5 series already, congratulations to all :)
Comment 8 Pino Toscano 2008-08-19 16:19:16 UTC
*** Bug 169441 has been marked as a duplicate of this bug. ***