Bug 161330 - Wobbly windows kwin effect mini conflicts whit the shadow one
Summary: Wobbly windows kwin effect mini conflicts whit the shadow one
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 2 votes (vote)
Target Milestone: ---
Assignee: Martin Flöser
URL:
Keywords:
: 163255 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-27 15:30 UTC by loic
Modified: 2008-11-06 08:27 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Kwin shadow wobble (532.54 KB, image/png)
2008-06-07 17:50 UTC, Sean Wilson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description loic 2008-04-27 15:30:44 UTC
Version:            (using Devel)
Installed from:    Compiled sources
OS:                Linux

Hi devs,

There is a little conflict when moving a windows if wobbly and shadow effects are both activated.

The shadow of the windows keep his rectangular shape and don't follow the wobbly style and the render is not esthetic.

Perhaps the solution is to use 
KWin::setShadowSize() 
to disabled the shadows of the windows during the moving (and of course don't forget to save the shadowsize parameter before the move and restore it after to correctly re-enabled it) ?

Cheers
Comment 1 Joe Kowalski 2008-05-01 19:54:37 UTC
What kwin needs to do is only draw the shadow layer for the window decoration, not the whole window. This alone slows down kwin considerably from having to have the graphics card do an alpha blend for a space the size of the whole window vs. just the pixels surrounding the window. 
Comment 2 cedric 2008-05-05 19:16:12 UTC
what I don't know with this problem, is what poeple expect.
Some poeple tells me that it is fine as is (personnaly, I don't like it), and you tell me to disable the shadow while the window moves.

The solution I prefer should be to draw the shadow with the same deformed shape of the window, but it looks tricky to me to do that (at least without heavy changes in the shadow plugin and kwin)
So I may end up with your solution for 4.1 and disable the shadow while the window moves.
Comment 3 jos poortvliet 2008-05-18 16:34:18 UTC
Disabling the shadow while moving seems like a decent solution for KDE 4.1. By the way, this looks even worse with a dark color scheme (and light 'shadow')...

What does compiz do? (imho there is no shame in looking at how compiz solves issues like these - reinventing the wheel is useless, after all, they've been around for a while, and have compositing pretty well done).
Comment 4 Pino Toscano 2008-06-05 10:22:49 UTC
*** Bug 163255 has been marked as a duplicate of this bug. ***
Comment 5 Sean Wilson 2008-06-07 17:50:15 UTC
Created attachment 25189 [details]
Kwin shadow wobble

Shows the window wobbling but shadow wobbling different.
Comment 6 Alexander Rössler 2008-06-24 23:44:15 UTC
I don't know if this is possible, but can't you draw a simple "fake" shadow for the wobbling effect and deactivate the original shadow? 
Comment 7 Luciano Leveroni 2008-07-12 05:49:11 UTC
This issue is still present in current 4.1 SVN (from 4.1 branch, not trunk).
If there isn't a quick solution, could you please disable the shadow when enabling the Wobbly windows effect for 4.1 final?
Thanks for your time.
Comment 8 Tsokar 2008-07-18 16:19:46 UTC
Same behaviour here with kde svn compiled today...
BtW I agree with L.Leveroni's comment.
Comment 9 Martin Flöser 2008-07-18 18:14:49 UTC
Currently it is not possible to disable one effect if another one gets enabled. I'm sorry this will not be possible.

Unfortunately there is not a quick solution. I started to work on it, but it will not be ready before 4.1 will be tagged as it requires some testing.
Comment 10 Andreas Kuhl 2008-11-05 17:08:21 UTC
Disabling the shadow during window movements is a less-then-ideal solution. Would be much better if the shadow would be wobbly too.
Comment 11 lucas 2008-11-06 06:24:08 UTC
Andreas, just FYI this bug has been fixed in 4.2--shadows now wobble with the window. The shadow disabling code is only for 4.1.
Comment 12 Andreas Kuhl 2008-11-06 08:27:49 UTC
Hey, this is good News! :)