Bug 161010 - "Modifier keys" tab from KDE3 is missing
Summary: "Modifier keys" tab from KDE3 is missing
Status: RESOLVED WORKSFORME
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_keys (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 61 votes (vote)
Target Milestone: ---
Assignee: Michael Jansen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-19 13:45 UTC by Vedran Furač
Modified: 2021-04-12 04:33 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vedran Furač 2008-04-19 13:45:46 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Application shortcuts, command shortcuts and modifier keys tabs are missing in KDE4
Comment 1 Jonathan Marten 2008-05-08 09:12:58 UTC
In KDE3 these options used to be available from Control Panel - Regional & Accessibility - Keyboard Shortcuts.

The corresponding place in KDE4, System Settings - Keyboard & Mouse - Keyboard Shortcuts, has only what used to be the "Global Shortcuts" settings.
Comment 2 Toke Høiland-Jørgensen 2008-08-01 13:42:48 UTC
I really miss these tabs as well; especially the "Application Shortcuts" tab. I really enjoyed being able to do a KDE-wide change of keys; specifically the "Delete word backwards" and "Close" bindings.
Comment 3 mehturt 2008-08-06 14:30:39 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Michael Jansen 2009-02-04 23:05:16 UTC
Parts of this bug report are fixed since 4.2.

With kmenuedit you can assign shortcuts to applications. see also kcmshell4 khotkeys. We could now discuss if it makes sense to add kmenuedit in system settings again.

I THINK keyboard shortcuts in kde3 is the same as global shortcuts in kde4. Correct?

the modifier keys are missing afaics.

After we established what's still missing i will accept and fix the remaining parts.
Comment 5 Vedran Furač 2009-02-05 01:59:04 UTC
Yes, only the "modifier keys" tab is still missing. Thank you for working on this.
Comment 6 Justin Zobel 2021-03-13 02:03:59 UTC
I believe this is now implemented under Personalization > Accessibility > Modifier Keys.

Can you please check and confirm if this can be resolved, thank you.

I've set this bug to NEEDSINFO. When you reply, please change the bug back to REPORTED so we know it's ready for investigation or RESOLVED/WORKSFORME if the issue is now resolved.
Comment 7 Bug Janitor Service 2021-03-28 04:33:32 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Bug Janitor Service 2021-04-12 04:33:23 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!