Bug 160826 - folder panel eats cpu time
Summary: folder panel eats cpu time
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 161312 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-14 16:57 UTC by Michi
Modified: 2008-05-10 15:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
1.dolphin before turning folders panel on (138.26 KB, image/jpeg)
2008-04-20 19:38 UTC, zOOm_ER
Details
2.dolphin after turning folders panel on (144.16 KB, image/jpeg)
2008-04-20 19:38 UTC, zOOm_ER
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michi 2008-04-14 16:57:36 UTC
Version:           1.0.99 (using 4.00.69 (KDE 4.0.69 >= 20080410) "release 2.5", compiled sources)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.25-rc9-mic

Hi,

since quite some time I've seen dolphin eating cpu time when the folders panel is activated. It also seems that the panel continuously repaints the tree content.
I'm running an x86_64 system with all the latest kde4 binaries from opensuse.

bye M;chi
Comment 1 Peter Penz 2008-04-16 20:16:38 UTC
Thanks for the report, but I cannot reproduce this issue on the latest SVN build :-( Could you please add a note to this bug report if you've tried to next Suse release? Thanks a lot in advance!
Comment 2 zOOm_ER 2008-04-20 19:38:14 UTC
Created attachment 24447 [details]
1.dolphin before turning folders panel on

1.dolphin before turning folders panel on
Comment 3 zOOm_ER 2008-04-20 19:38:56 UTC
Created attachment 24448 [details]
2.dolphin after turning folders panel on

2.dolphin after turning folders panel on
Comment 4 zOOm_ER 2008-04-20 19:39:44 UTC
I also encounter this bug.
KDE 4.0.3 from OpenSUSE 11.0b1.
Dolphin version 1.0.2

attached screenshots:
1) Dolphin before turning on 'folders' panel - consumes no CPU
2) After turning panel on (View-panels-folders) it eats 1\3 of my CPU

And by the way - after closing 'folders' panel, Dolphin continues to consume CPU.
Comment 5 Peter Penz 2008-04-20 23:34:26 UTC
I could reproduce this issue on SVN latest, but not with the 1.0.2 version. I'll check the root cause and will backport the fix if it is a general problem.
Comment 6 Peter Penz 2008-04-27 22:48:20 UTC
*** Bug 161312 has been marked as a duplicate of this bug. ***
Comment 7 Rafael Fernández López 2008-05-02 19:19:35 UTC
SVN commit 803361 by ereslibre:

Fix CPU 100% bug. This hack couldn't live much more. Peter, about the "we get to an unusabla tree view", I've worked on a patch for QTreeView. Let's see if TT like it :)

BUG: 160826


 M  +0 -3      sidebartreeview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=803361
Comment 8 Peter Penz 2008-05-10 15:48:18 UTC
SVN commit 806202 by ppenz:

Backport SVN commit 803361 (fix CPU 100 % bug).

CCBUG: 160826

 M  +0 -3      sidebartreeview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=806202