Bug 160634 - application crash on logout
Summary: application crash on logout
Status: RESOLVED FIXED
Alias: None
Product: klipper
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Esben Mose Hansen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-10 02:49 UTC by Joseph Tate
Modified: 2008-04-13 17:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Tate 2008-04-10 02:49:43 UTC
Version:           4.0 branch revision r793299 (using Devel)
Installed from:    Compiled sources
Compiler:          4.1.2 
OS:                Linux

Every time I logout of my kde4 session, klipper crashes.  I've managed to save a crash dump:

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0x2ac0ab360730 (LWP 3886)]
[KCrash handler]
#4  0x00002ac0a47f5ab3 in ~URLGrabber (this=0x74afe0)
    at /usr/src/debug/kdebase--kdebase/workspace/klipper/urlgrabber.cpp:87
#5  0x00002ac0a47f042a in ~Klipper (this=0x747900)
    at /usr/src/debug/kdebase--kdebase/workspace/klipper/klipper.cpp:210
#6  0x00002ac0a4e4c807 in QObjectPrivate::deleteChildren ()
   from /usr/lib64/libQtCore.so.4
#7  0x00002ac0a4e50b2f in QObject::~QObject () from /usr/lib64/libQtCore.so.4
#8  0x00002ac0a480423b in kdemain (argc=1, argv=<value optimized out>)
    at /usr/src/debug/kdebase--kdebase/workspace/klipper/tray.h:29
#9  0x00002ac0a4a2a8a4 in __libc_start_main () from /lib64/libc.so.6
#10 0x00000000004005c9 in _start ()
Comment 1 Joseph Tate 2008-04-10 02:50:23 UTC
Should mention that this is an x86_64 build.
Comment 2 Urs Wolfer 2008-04-10 22:30:26 UTC
SVN commit 795575 by uwolfer:

Be more careful with deleting QObject.
Should hopefully fix the crash reported in 160634. Please try and comment here if there are still problems. (I cannot reproduce this issue.)
BUG:160634

 M  +5 -4      urlgrabber.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=795575
Comment 3 Joseph Tate 2008-04-11 06:02:51 UTC
Thanks.  That seems to have fixed it.  It applies cleanly to the 4.0 branch, can you merge it please?
Comment 4 Urs Wolfer 2008-04-13 17:33:00 UTC
SVN commit 796437 by uwolfer:

Backport:
SVN commit 795575 by uwolfer:

Be more careful with deleting QObject.
Should hopefully fix the crash reported in 160634. Please try and comment here if there are still problems. (I cannot reproduce this issue.)
CCBUG:160634

 M  +5 -4      urlgrabber.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=796437