Bug 160422 - How does konsole choose its very first initial size?
Summary: How does konsole choose its very first initial size?
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 159208 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-05 18:57 UTC by Mary Ellen Foster
Modified: 2008-06-02 08:29 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mary Ellen Foster 2008-04-05 18:57:48 UTC
Version:            (using KDE 4.0.3)
Installed from:    Fedora RPMs
OS:                Linux

I have read bug 155603 and I understand that size-setting in konsole works differently in KDE 4. But how does konsole choose its very first size? At least on my Fedora machine, the initial konsole opens at 78x24 on my smallish laptop display and about 78x40 on my larger desktop machine. It would be nice if this initial size was at least 80 characters wide, as some programs assume that as a minimum.
Comment 1 Robert Knight 2008-04-05 21:17:09 UTC
SVN commit 793964 by knight:

Fix calculation of required display size given (lines,columns) in
TerminalDisplay widget.  Include width of vertical scrollbar (if visible)
and top/left margins.  Konsole will now start with a default width of 80 columns
on most systems if no window size has been saved in konsolerc

The initial size of Konsole is specified as 80x40 internally.  Qt constrains
the size of top-level windows on their first automatic resize to a
maximum of 2/3rds of the screen size (see QWidgetPrivate::adjustedSize()).
This means that the display might not get the 80x40 columns that it asks
for, depending on the desktop size.

CCBUG: 160422


 M  +8 -8      TerminalDisplay.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=793964
Comment 2 Robert Knight 2008-04-05 21:50:37 UTC
SVN commit 793970 by knight:

If the main window size has not been manually set by the time it is shown
(which will be the case on non-first runs) then manually resize it to
its sizeHint() to work around Qt's restriction on the relative size of
top level windows compared to the desktop size.

CCBUG: 160422


 M  +16 -1     Application.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=793970
Comment 3 Kevin Kofler 2008-04-09 19:46:04 UTC
*** Bug 159208 has been marked as a duplicate of this bug. ***
Comment 4 Kevin Kofler 2008-04-26 01:56:00 UTC
Can this stuff be backported to 4.0? Or is this considered a "feature" rather than a "bug"?
Comment 5 Robert Knight 2008-06-02 08:29:31 UTC
> Can this stuff be backported to 4.0? Or is this considered a "feature" rather than a "bug"? 

I'm not sure that there is a lot of point given the problems that other parts of KDE 4.0 have.  

Realistically speaking, KDE 4.1 is the first version of KDE 4 that will be suitable for widespread use and I understand that Fedora will be putting KDE 4.1 in F9.  I understand that other distributions shipping 4.0 as "experimental" will be making 4.1 readily available as well.