Bug 160393 - kwin dont display gtk apllications
Summary: kwin dont display gtk apllications
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 164618 165259 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-05 12:06 UTC by Milan Krivda
Modified: 2011-08-23 23:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Krivda 2008-04-05 12:06:19 UTC
Version:            (using KDE 4.0.3)
Installed from:    Gentoo Packages

I started KDE without kwin effects. Opened some GTK applications (Firefox and GIMP). I work with photos and i want better orientation in opened photos, them i enabled desktop effects and all GTK windows disappeared. On taskbar i see this applications, when i hover over task i see preview, but windows aren't visible. Closing and starting GTK apps with enabled effects run fine.
Comment 1 Lubos Lunak 2008-05-14 11:49:13 UTC
Which driver, which compositing mode (opengl/xrender)?
Comment 2 Lubos Lunak 2008-06-05 15:30:46 UTC
SVN commit 817185 by lunakl:

Don't avoid windows that don't have contents yet ready for painting.
There is a bug somewhere in detecting it and there also should be
a protection against faulty clients.
CCBUG: 160393



 M  +1 -1      composite.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=817185
Comment 3 lucas 2008-06-22 05:50:05 UTC
*** Bug 164618 has been marked as a duplicate of this bug. ***
Comment 4 lucas 2008-06-29 03:20:52 UTC
*** Bug 165259 has been marked as a duplicate of this bug. ***
Comment 5 Lubos Lunak 2008-06-29 15:11:48 UTC
SVN commit 825817 by lunakl:

Disable the code that prevented clients not-yet-ready-for-painting
from being shown. There is a bug somewhere and it should be improved
in general.
BUG: 160393



 M  +8 -0      composite.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=825817
Comment 6 Thomas Lübking 2011-08-23 23:41:49 UTC
Git commit b81ba5968daf39bdb1299f30454ac13131fa3fd9 by Thomas Lübking.
Committed on 13/08/2011 at 16:39.
Pushed by luebking into branch 'master'.

fix xsync protocol

BUG: 160393
REVIEW: 102311

M  +10   -9    kwin/client.h
M  +27   -27   kwin/geometry.cpp
M  +11   -9    kwin/events.cpp
M  +41   -19   kwin/client.cpp
M  +13   -12   kwin/composite.cpp
M  +2    -0    kwin/manage.cpp

http://commits.kde.org/kde-workspace/b81ba5968daf39bdb1299f30454ac13131fa3fd9