Bug 160044 - konq: cookie dialogs come up behind the main window
Summary: konq: cookie dialogs come up behind the main window
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: kcookiejar (show other bugs)
Version: 4.1.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 168763 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-29 00:09 UTC by missive
Modified: 2011-11-26 18:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description missive 2008-03-29 00:09:38 UTC
Version:           4.0.2 (KDE 4.0.2) (using 4.0.2 (KDE 4.0.2), Kubuntu packages)
Compiler:          gcc
OS:                Linux (i686) release 2.6.22-14-generic

Using konq in 4.0.2

I have the cookie setting to "ask", focus set to "focus follows mouse" and focus stealing prevention set to "low".

I thought that maybe I was inadvertently clicking in the window and bringing it forward over top of the cookie dialog, but it does not seem to be the case.
Comment 1 FiNeX 2008-03-29 13:49:30 UTC
It has happened to me some times too.
Comment 2 Peter Lewis 2008-07-29 11:16:36 UTC
Confirmed. I get this behaviour with "focus prevention stealing" == low in KDE 4.0.98.
Comment 3 Maksim Orlovich 2010-06-06 19:35:01 UTC
*** Bug 168763 has been marked as a duplicate of this bug. ***
Comment 4 Dawit Alemayehu 2011-11-26 18:15:50 UTC
Git commit 33306f48b30d8d7a0210eeafe9a3a4eb561ab0c6 by Dawit Alemayehu.
Committed on 26/11/2011 at 08:59.
Pushed by adawit into branch 'KDE/4.7'.

Just like the password dialog, associate the cookie configuration dialog with
the correct parent window.

BUG: 123504
BUG: 160044
FIXED-IN: 4.7.4

M  +18   -5    kioslave/http/kcookiejar/kcookieserver.cpp
M  +3    -0    kioslave/http/kcookiejar/kcookieserver.h

http://commits.kde.org/kdelibs/33306f48b30d8d7a0210eeafe9a3a4eb561ab0c6