Bug 159111 - show cover switch with dual screen only on current screen
Summary: show cover switch with dual screen only on current screen
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Martin Flöser
URL:
Keywords:
: 159781 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-11 00:10 UTC by FiNeX
Modified: 2008-04-28 19:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FiNeX 2008-03-11 00:10:50 UTC
Version:            (using Devel)
Installed from:    Compiled sources

The "cover switch" effect of kwin should be displayed only on the current screen in a multi monitor setup.
Comment 1 Martin Flöser 2008-03-11 14:51:13 UTC
same bug appears in flip switch
Comment 2 FiNeX 2008-03-24 12:40:55 UTC
*** Bug 159781 has been marked as a duplicate of this bug. ***
Comment 3 Martin Flöser 2008-04-17 16:16:28 UTC
SVN commit 798109 by graesslin:

Makes CoverSwitch working with TwinView/Xinerama Settings. Switching is now only shown on the current screen and not extended to both screens.
CCBUG: 159111

 M  +104 -29   coverswitch.cpp  
 M  +2 -0      coverswitch.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=798109
Comment 4 Martin Flöser 2008-04-28 19:53:23 UTC
SVN commit 802160 by graesslin:

Bring some changes from coverswitch to flipswitch (we should have a superclass for those two effects):
 * Physic based animation via TimeLine
 * Default animation 200 msec
 * Fade in and out panel and window caption box during start/stop animation
 * Switch to stop animation if alt+tab is released during start animation
 * TwinView/Xinerama support

BUG: 159111

 M  +146 -40   flipswitch.cpp  
 M  +3 -1      flipswitch.h  
 M  +2 -2      flipswitch_config.cpp  
 M  +1 -1      flipswitch_config.ui  


WebSVN link: http://websvn.kde.org/?view=rev&revision=802160