Bug 158955 - kgpg don't stay in systray when clicking on the window's cross button
Summary: kgpg don't stay in systray when clicking on the window's cross button
Status: RESOLVED FIXED
Alias: None
Product: kgpg
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Rolf Eike Beer
URL:
Keywords:
: 160932 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-08 09:52 UTC by thomas klein
Modified: 2008-07-22 23:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thomas klein 2008-03-08 09:52:41 UTC
Version:            (using KDE 4.0.2)
Installed from:    Ubuntu Packages
OS:                Linux

kgpg don't stay in systray when clicking on the window's cross button, it quits.
Comment 1 thomas klein 2008-03-08 09:55:27 UTC
even when quiting kgpg editor, kgpg quits entirely
Comment 2 thomas klein 2008-04-02 20:28:45 UTC
bug still present in 4.0.3
Comment 3 Rolf Eike Beer 2008-04-17 18:09:06 UTC
*** Bug 160932 has been marked as a duplicate of this bug. ***
Comment 4 Rolf Eike Beer 2008-05-08 19:46:38 UTC
SVN commit 805531 by dakon:

Only minimize to tray if user closes the keysmanager window

Backport of r805479

BUG:158955

Let's try to close the right bug this time :/


 M  +4 -4      keysmanager.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=805531
Comment 5 Rolf Eike Beer 2008-07-22 23:16:01 UTC
SVN commit 836735 by dakon:

improve "minimize to tray on window close"

Everything that still goes wrong is a KMainWindow bug ;) Thanks to dfaure for 
pointing me in the right direction.

CCBUG:158955


 M  +0 -10     keysmanager.cpp  
 M  +0 -2      keysmanager.h  
 M  +1 -12     kgpgeditor.cpp  
 M  +0 -3      kgpgeditor.h  
 M  +1 -0      main.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=836735