Bug 158194 - K3B crashes when converting to mp3
Summary: K3B crashes when converting to mp3
Status: RESOLVED WORKSFORME
Alias: None
Product: k3b
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-21 22:10 UTC by Ken Jones
Modified: 2009-05-30 15:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Jones 2008-02-21 22:10:22 UTC
Version:           1.0.4 (using 3.5.8, Kubuntu (gutsy) 4:3.5.8-0ubuntu3.3)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.22-14-generic

Wav files dragged into project window. Convert button clicked and .mpg3 location specified. Click OK. K3B crashes during conversion.

Backtrace follows-

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1235933504 (LWP 12171)]
[New Thread -1286116464 (LWP 21089)]
0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb6852676 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb6dbcbe6 in QThread::wait () from /usr/lib/libqt-mt.so.3
#3  0xb7d99085 in K3bThread::waitUntilFinished () from /usr/lib/libk3b.so.3
#4  0x08090cb8 in K3bApplication::qt_invoke ()
#5  0xb6e2d9c0 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#6  0xb6e2e338 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#7  0xb74b37ac in KApplication::shutDown () from /usr/lib/libkdecore.so.4
#8  0xb74b387e in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#9  0xb74b38d9 in ?? () from /usr/lib/libkdecore.so.4
#10 0xbfa78464 in ?? ()
#11 0x082771c8 in ?? ()
#12 0xbfa75ed4 in ?? ()
#13 0x082771c8 in ?? ()
#14 0xb74b38b9 in ?? () from /usr/lib/libkdecore.so.4
#15 0xb696fb2c in ?? () from /usr/lib/libX11.so.6
#16 0xbfa75e98 in ?? ()
#17 0xb68bed4d in _XIOError () from /usr/lib/libX11.so.6
Backtrace stopped: frame did not save the PC
Comment 1 Lubos Lunak 2008-07-21 16:23:01 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 2 Dario Andres 2009-05-29 20:59:06 UTC
Is this still valid with a current K3b version ? Thanks
Comment 3 Ken Jones 2009-05-30 08:34:51 UTC
Version 3.5.10 works fine.(In reply to comment #2)
> Is this still valid with a current K3b version ? Thanks
Comment 4 Dario Andres 2009-05-30 15:22:50 UTC
Thanks. Closing as WORKSFORME